summaryrefslogtreecommitdiff
path: root/dev-haskell/mustache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/mustache
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/mustache')
-rw-r--r--dev-haskell/mustache/Manifest3
-rw-r--r--dev-haskell/mustache/metadata.xml16
-rw-r--r--dev-haskell/mustache/mustache-2.3.1.ebuild44
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-haskell/mustache/Manifest b/dev-haskell/mustache/Manifest
new file mode 100644
index 000000000000..3e89002a4ee1
--- /dev/null
+++ b/dev-haskell/mustache/Manifest
@@ -0,0 +1,3 @@
+DIST mustache-2.3.1.tar.gz 20207 BLAKE2B 87691b14e85ac5934c08d1b3f8261d6e7bb3786b808d0f1a04630b96b4f2ed4aeae4d049ccf0e408b47586e990db2bbc09e3eac56af67922538e73250ef486d5 SHA512 162360cb635d40086721d4dd350036884207679b240d30420b9fc71eebef847e542bd143275931a22a42c583d513d0c906a6b112d780824dc189ad07e3027aa3
+EBUILD mustache-2.3.1.ebuild 1123 BLAKE2B b99008b9059701ea7994d54612bafc83ad6ec0d9b45da5bfc0a2a8508f54ada4a2aff60ae2e6577d84cbd763a3df6d151a097013a2f8fa182703a2de0d92abe6 SHA512 d6c822d2a7b0180b92ad89d1c8a78bf4427027658ea6e1e3296b4eb7379c77a1696b99b681396e06c1f8e9e0d650592beffa200d6a678a7527f9b471b60025cb
+MISC metadata.xml 576 BLAKE2B eaab68066642d76246155fa2218ab83f19e285a08563343c420647ab679a3cc721abf98328c927ca412bb4d7f478759a9ebd4475339ba6016119e78627f3a788 SHA512 feabd7703243f794c0e31ada7d39911677ddcfafbb0d1a6f1d832d9cfff4027863019fcaa5f5322dbef37043b968620ff4957fdfae1e42ec706661291b78d57b
diff --git a/dev-haskell/mustache/metadata.xml b/dev-haskell/mustache/metadata.xml
new file mode 100644
index 000000000000..546170479152
--- /dev/null
+++ b/dev-haskell/mustache/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Allows parsing and rendering template files with mustache markup. See the
+ mustache &lt;http://mustache.github.io/mustache.5.html language reference&gt;.
+
+ Implements the mustache spec version 1.1.3.
+
+ /Note/: Versions including and beyond 0.4 are compatible with ghc 7.8 again.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mustache/mustache-2.3.1.ebuild b/dev-haskell/mustache/mustache-2.3.1.ebuild
new file mode 100644
index 000000000000..23b768a9e9d5
--- /dev/null
+++ b/dev-haskell/mustache/mustache-2.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A mustache template parser library"
+HOMEPAGE="https://github.com/JustusAdam/mustache"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # tries to access network
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/cmdargs:=[profile?]
+ dev-haskell/either:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/th-lift:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( dev-haskell/base-unicode-symbols
+ dev-haskell/hspec
+ dev-haskell/lens
+ dev-haskell/tar
+ dev-haskell/temporary
+ dev-haskell/wreq
+ dev-haskell/zlib )
+"