summaryrefslogtreecommitdiff
path: root/dev-haskell/mmap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/mmap
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/mmap')
-rw-r--r--dev-haskell/mmap/Manifest5
-rw-r--r--dev-haskell/mmap/metadata.xml15
-rw-r--r--dev-haskell/mmap/mmap-0.5.8.ebuild43
-rw-r--r--dev-haskell/mmap/mmap-0.5.9.ebuild43
4 files changed, 106 insertions, 0 deletions
diff --git a/dev-haskell/mmap/Manifest b/dev-haskell/mmap/Manifest
new file mode 100644
index 000000000000..a49f1ce6d758
--- /dev/null
+++ b/dev-haskell/mmap/Manifest
@@ -0,0 +1,5 @@
+DIST mmap-0.5.8.tar.gz 11657 BLAKE2B 875557d3f28260028368a8979f398f13e501be507ebdb5bc098935c1ef3dff05fc7b7d7abbf29e632f0368e19b952b466ee7f192cb3cf4f4944009fa525ab7d9 SHA512 6c8b526ec9fedba195ce021f86eeb3fa35f7c95b9299d17503ad7d7e91b9485b3d9980e0ccbdc3876ec465ec8aa07cf9d0521c62e2c8a652a36df11b9badffb5
+DIST mmap-0.5.9.tar.gz 11731 BLAKE2B 1a2133f487f9b214c8a4be3aa91a38ee849b40649b77eec8e656fbd99d32c31761d1daeb474a56e9e0611db631a22828ab20171c6522f324e278ace0de0dac2e SHA512 3b9ac1150050ac9d8e7870610923c8303b5fc74a4fdd796d7b6b411e2ba836111ae8520e16ad345aaf93b4dbcd27abd4c359a89b27d854db8dbd252b90a5298d
+EBUILD mmap-0.5.8.ebuild 1154 BLAKE2B a168ed8c3c9567713b6844ec4b106295ad7e55af383c12e4f98bfcbe811537fc59c185cd576ad7b2d0e876e05f00b77ed8c11e525f611bd552bc8b0f609fa751 SHA512 7fad85981cdf441c8110fe9354c974b72634bf01a4de44d76cf507e5e79a1f5381efdfa4bb297704355162bc2bac820eb8b97fb2ca5d7ec741bfa4fb1405890f
+EBUILD mmap-0.5.9.ebuild 1161 BLAKE2B 7b63379bc5bda55de663645222666a926598d7c6699e673f91092f2892a07a4556e978b1f9db4fac1263d0dc766cb88e52606cc47bb323d8424ce4ffaf6bfa68 SHA512 d1051077bca0f907fa3c1b12e900082ba097092ea8da35ccc7181e7e4787fd4925f500ab7c9113e1486a9f2eeaa0c5fe06685ce6443f27daf597f182472da20e
+MISC metadata.xml 569 BLAKE2B 132fd4404bb9c963ca46ab92df1bd4bcff4bd33bb493f079154aaa44d9cce5b8accc3c44dca3605db23f2b92093ec4835dcd085a4f44d748280313e3df6c0409 SHA512 6e13722dae998496bbaafe7f1d9b93e041452d0adb0987ad52ab141923217f06e15430fe873041dfe247ba3d7bee6e4a0c2539e1f623dff4df75935fd8528c80
diff --git a/dev-haskell/mmap/metadata.xml b/dev-haskell/mmap/metadata.xml
new file mode 100644
index 000000000000..d6079ee99c4c
--- /dev/null
+++ b/dev-haskell/mmap/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This library provides a wrapper to mmap(2) or MapViewOfFile,
+ allowing files or devices to be lazily loaded into memory as
+ strict or lazy ByteStrings, ForeignPtrs or plain Ptrs, using
+ the virtual memory subsystem to do on-demand loading.
+ Modifications are also supported.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/mmap/mmap-0.5.8.ebuild b/dev-haskell/mmap/mmap-0.5.8.ebuild
new file mode 100644
index 000000000000..d3fd5291728d
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}
diff --git a/dev-haskell/mmap/mmap-0.5.9.ebuild b/dev-haskell/mmap/mmap-0.5.9.ebuild
new file mode 100644
index 000000000000..07394084092f
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}