summaryrefslogtreecommitdiff
path: root/dev-haskell/mmap/mmap-0.5.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/mmap/mmap-0.5.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/mmap/mmap-0.5.9.ebuild')
-rw-r--r--dev-haskell/mmap/mmap-0.5.9.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-haskell/mmap/mmap-0.5.9.ebuild b/dev-haskell/mmap/mmap-0.5.9.ebuild
new file mode 100644
index 000000000000..07394084092f
--- /dev/null
+++ b/dev-haskell/mmap/mmap-0.5.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Memory mapped files for POSIX and Windows"
+HOMEPAGE="http://hackage.haskell.org/package/mmap"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# IUSE="test"
+IUSE=""
+
+RESTRICT="test" # the test suite compile fails: Not in scope: data constructor `Permissions'
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+# test? ( dev-haskell/hunit[profile?] )" # pcheck dislikes useless depends
+
+src_configure() {
+ cabal_src_configure # $(cabal_flag test mmaptest)
+}
+
+src_test() {
+ # breaking the abstraction a bit, we're not supposed to know about ./setup
+ # and how it works...
+ ./dist/build/mmaptest/mmaptest || die "tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ rm "${D}/usr/bin/mmaptest"
+ rmdir "${D}/usr/bin" 2> /dev/null # only if empty
+}