summaryrefslogtreecommitdiff
path: root/dev-haskell/lvmlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/lvmlib
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/lvmlib')
-rw-r--r--dev-haskell/lvmlib/Manifest6
-rw-r--r--dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch87
-rw-r--r--dev-haskell/lvmlib/lvmlib-1.1.ebuild30
-rw-r--r--dev-haskell/lvmlib/metadata.xml17
4 files changed, 140 insertions, 0 deletions
diff --git a/dev-haskell/lvmlib/Manifest b/dev-haskell/lvmlib/Manifest
new file mode 100644
index 000000000000..4b6ca15214b1
--- /dev/null
+++ b/dev-haskell/lvmlib/Manifest
@@ -0,0 +1,6 @@
+AUX lvmlib-1.1-ghc-7.10.patch 2590 SHA256 ac84bc376560e8ad9d050aa6ac09408cc4899d39a55344b58ecd6ea62938a4e4 SHA512 a645db9a37614752afa29d176133ee237511773e1d7c8d2f5959828264ad909360f441673b3e6bef5137bb0deb2f1eb108371032fafaa77a86d5a7be5fec2867 WHIRLPOOL b727ab82ec07be7f08a75328b17bb50b82e9f2fe7116c8497851dc1d99e6131f419dd626251335d1e40e1f0456f5c01a0c78cf4e8db2bdd78e2cf666aa69d26d
+DIST lvmlib-1.1.tar.gz 62388 SHA256 6f99e1ed437d45ecdbb019185d24bc920f7965f279f3b1cec268d51350c622d3 SHA512 3f085f3ff8e53ab19de3b425c4c5a271111afcd334ec08fefd983838608ae436005c20c2d7c545650f0dd1b76d466f81661a14c8ce972df27d79a78c22023861 WHIRLPOOL 51335de8c29e9317bb0fb18f31aa0478dfe603f1c982730501636aee5099f833e9b205869a519eba7e84de291347024406b09dd084edbcc7ab04be33714be5e8
+EBUILD lvmlib-1.1.ebuild 699 SHA256 833c75266d7f36dc3dca889eed521d732f28abeadc602b269a02e29716358fbd SHA512 24c6d760a95b75f996a803d01099bf7a7c75edc07de5b5422f21d36db1825fc2e53fb082f79fec75764e99215b98a14fac089803eaa64445f4a526669022ce9b WHIRLPOOL 32dbe792483267f80d8c5ae67a6a3fceb2d808d605f1474a990930743f025dea694bace48692a28173c08b44ebc249831d7171fd8496b7e25cc48f63a951e49b
+MISC ChangeLog 2850 SHA256 5cd9f303b3f60301d4ef7f2a4b4d0a442573fb8b57cebcfc2e88374b64738ddf SHA512 8161241a86cba0c8152ee6821b58b8e2fe1f225a0978e21fc3c3dbc06b858ae60f11a56c413de8e21e467fbe238b71702c7871f0eaf60ed369892dbd1194ece5 WHIRLPOOL b2376654b723d7790958a8a6c334b017f53747120566eaaf0020ca0b5cb4e786b006f048a9b15f173b330179c0b641c43b96491c5beee1ad33d64b343f06cec8
+MISC ChangeLog-2015 563 SHA256 446261478b19063f70599038c76a17583c0623422059318d7bb1ad6618700a8c SHA512 91ce4da94d22071d3296f3cae75a4c3343848b6a74332770cd8741de5e280eb328140fe3f48e428a324b62299d8b05590f8f9851ee59a98ddc19dca8f7e07f46 WHIRLPOOL d4071a3b5793bfb721783a4ca7bd3d64cec07788f970db94c6507db1ba2959aac01bb3ab681c21c61d72d9c22248d077ea5732d52f90a84f6e8d33b491023889
+MISC metadata.xml 822 SHA256 fb2e96c01e309558531b655aaa8fea739038d60a53883a662d9703a7e21001f6 SHA512 95c53741b0af7d02006f5715e9468b01d984c5145a4f0582f268da5c3ef19c7902d7a9fe48a8b07c1825dbe9a8e09cc03c208a405218ec930b72ddd9e9d31219 WHIRLPOOL b2948e9a6fdeeed0c2be9aa26ee712c7dc2ba28a637e6f3b5bf4b626f1cf2b27961cff9d80f07b9805d1f492d1fc327165b06883899452cf7191f83501f0c876
diff --git a/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
new file mode 100644
index 000000000000..ad68d78f56e7
--- /dev/null
+++ b/dev-haskell/lvmlib/files/lvmlib-1.1-ghc-7.10.patch
@@ -0,0 +1,87 @@
+diff --git a/Lvm/Asm/Data.hs b/Lvm/Asm/Data.hs
+index 7939754..f3da0b7 100644
+--- a/Lvm/Asm/Data.hs
++++ b/Lvm/Asm/Data.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.Module
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Common/IdMap.hs b/Lvm/Common/IdMap.hs
+index a50bcb6..10758e6 100644
+--- a/Lvm/Common/IdMap.hs
++++ b/Lvm/Common/IdMap.hs
+@@ -24,2 +24,3 @@ import Lvm.Common.Id
+ import Control.Arrow (first)
++import Prelude hiding (foldMap)
+
+diff --git a/Lvm/Core/Expr.hs b/Lvm/Core/Expr.hs
+index 8bc50d7..935e16a 100644
+--- a/Lvm/Core/Expr.hs
++++ b/Lvm/Core/Expr.hs
+@@ -17,2 +17,3 @@ import Lvm.Core.PrettyId
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Core/Module.hs b/Lvm/Core/Module.hs
+index 923870e..ac52201 100644
+--- a/Lvm/Core/Module.hs
++++ b/Lvm/Core/Module.hs
+@@ -24,2 +24,3 @@ import Lvm.Instr.Data
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Data.hs b/Lvm/Instr/Data.hs
+index 497a690..959cb5c 100644
+--- a/Lvm/Instr/Data.hs
++++ b/Lvm/Instr/Data.hs
+@@ -19,2 +19,3 @@ import Lvm.Common.Id
+ import Text.PrettyPrint.Leijen
++import Prelude hiding ((<$>))
+
+diff --git a/Lvm/Instr/Resolve.hs b/Lvm/Instr/Resolve.hs
+index 6845f74..4172a74 100644
+--- a/Lvm/Instr/Resolve.hs
++++ b/Lvm/Instr/Resolve.hs
+@@ -10,2 +10,4 @@ module Lvm.Instr.Resolve (instrResolve) where
+ import Control.Exception (assert)
++import Control.Applicative
++import Control.Monad
+ import Data.Maybe
+@@ -32,2 +34,6 @@ instance Functor Resolve where
+
++instance Applicative Resolve where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Resolve where
+diff --git a/Lvm/Read.hs b/Lvm/Read.hs
+index 7137331..25797f9 100644
+--- a/Lvm/Read.hs
++++ b/Lvm/Read.hs
+@@ -9,2 +9,3 @@ module Lvm.Read (lvmReadFile, lvmRead) where
+
++import Control.Applicative
+ import Control.Monad
+@@ -390,2 +391,7 @@ instance Functor (Read v) where
+ Result x st2 -> Result (f x) st2)
++
++instance Applicative (Read v) where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad (Read v) where
+diff --git a/Lvm/Write.hs b/Lvm/Write.hs
+index 48570f8..37469bc 100644
+--- a/Lvm/Write.hs
++++ b/Lvm/Write.hs
+@@ -11,2 +11,3 @@ import qualified Control.Exception as CE (assert, catch, IOException)
+ import Control.Monad
++import Control.Applicative
+ import Data.Maybe
+@@ -465,2 +466,6 @@ instance Functor Emit where
+
++instance Applicative Emit where
++ pure = return
++ (<*>) = ap -- defined in Control.Monad
++
+ instance Monad Emit where
diff --git a/dev-haskell/lvmlib/lvmlib-1.1.ebuild b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
new file mode 100644
index 000000000000..0b49945b9a5b
--- /dev/null
+++ b/dev-haskell/lvmlib/lvmlib-1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit eutils haskell-cabal
+
+DESCRIPTION="The Lazy Virtual Machine (LVM)"
+HOMEPAGE="http://www.cs.uu.nl/wiki/bin/view/Helium/WebHome"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/parsec:=[profile?]
+ dev-haskell/wl-pprint:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10.1.0
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-ghc-7.10.patch
+}
diff --git a/dev-haskell/lvmlib/metadata.xml b/dev-haskell/lvmlib/metadata.xml
new file mode 100644
index 000000000000..2d49cd8f1b3c
--- /dev/null
+++ b/dev-haskell/lvmlib/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The Lazy Virtual Machine (LVM) defines a portable instruction set and file
+ format. It is specifically designed to execute languages with non-strict (or
+ lazy) semantics. This cabal package defines the core assembler (coreasm) for
+ compiling core programs into LVM instructions and a library. The LVM is used
+ as a backend for the Helium compiler. At the moment, one LVM runtime
+ implementation is available (written in C). More information about LVM can be
+ found in Chapter 6 of Daan Leijen's PhD Thesis, The Lambda Abroad.
+ </longdescription>
+</pkgmetadata>