summaryrefslogtreecommitdiff
path: root/dev-haskell/lukko
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/lukko
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/lukko')
-rw-r--r--dev-haskell/lukko/Manifest3
-rw-r--r--dev-haskell/lukko/lukko-0.1.1.2.ebuild36
-rw-r--r--dev-haskell/lukko/metadata.xml47
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-haskell/lukko/Manifest b/dev-haskell/lukko/Manifest
new file mode 100644
index 000000000000..503f6424a34b
--- /dev/null
+++ b/dev-haskell/lukko/Manifest
@@ -0,0 +1,3 @@
+DIST lukko-0.1.1.2.tar.gz 28366 BLAKE2B 8e7a0257c187ed76f2399a2ca381210ad44d683faff74ca583658eab13545e6809fe6ea57b4c4c22c16560272c0d53736183437e4f5ad64919d98dbac239a864 SHA512 fe3a6687b741491ebaeace29c8d4d01307fad43f0e649c087fef24ec227eb231541fa1500e1685c814eb2a1ea472546033e837ce84fa64df79f00b19f8abebb6
+EBUILD lukko-0.1.1.2.ebuild 1084 BLAKE2B 01d56641070b69a1263c841558daced98987b7b5a7291075c5b364426f1a5489cb846c9c5883978d826917ceede47bdb7f25b4c613899540bcd2bb230ac35686 SHA512 7c73a0bc57e44cf2a32d9566af68ec5e2773fca8bc51a4d0f71e1cf3f0964f123abdf74a451d39bd5521f3f5f6314259f03cb534fa317986e48e0bbc93dcb6f0
+MISC metadata.xml 1775 BLAKE2B c2465f50a55356961ce4e30d005a76589fcfdf1ebb5f985e9415fe39b39767b9c02872cbc4a371441af240257b9d8d27e731b3e012b65beb60e45767c98035f9 SHA512 c8b0386734f1810ec1c2e693b5686e0ef0e5c9789794e393df47991341a5011ce079de92888763394a9867ea86fc2a205f13271ecf9af22207e4e7244a0c0d4b
diff --git a/dev-haskell/lukko/lukko-0.1.1.2.ebuild b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
new file mode 100644
index 000000000000..6dcaf99f3e07
--- /dev/null
+++ b/dev-haskell/lukko/lukko-0.1.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="File locking"
+HOMEPAGE="https://hackage.haskell.org/package/lukko"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ofd-locking"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2
+ test? ( >=dev-haskell/async-2.2.2 <dev-haskell/async-2.3
+ >=dev-haskell/singleton-bool-0.1.5 <dev-haskell/singleton-bool-0.2
+ >=dev-haskell/tagged-0.8.5 <dev-haskell/tagged-0.9
+ >=dev-haskell/tasty-1.2.3 <dev-haskell/tasty-1.3
+ >=dev-haskell/tasty-expected-failure-0.11.1.2 <dev-haskell/tasty-expected-failure-0.12
+ >=dev-haskell/tasty-hunit-0.10.0.2 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/temporary-1.3 <dev-haskell/temporary-1.4 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag ofd-locking ofd-locking)
+}
diff --git a/dev-haskell/lukko/metadata.xml b/dev-haskell/lukko/metadata.xml
new file mode 100644
index 000000000000..a2f47beee925
--- /dev/null
+++ b/dev-haskell/lukko/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="ofd-locking">Enable open file descriptor locking. Available on Linux (kernel 3.15, released Jun 8, 2014).</flag>
+ </use>
+ <longdescription>
+ This package provides access to platform dependent file locking APIs:
+
+ * Open file descriptor locking on Linux (&quot;Lukko.OFD&quot;)
+ * @flock@ locking on unix platforms (&quot;Lukko.FLock&quot;)
+ * Windows locking @LockFileEx@ (&quot;Lukko.Windows&quot;)
+ * No-op locking, which throws exceptions (&quot;Lukko.NoOp&quot;)
+ * &quot;Lukko&quot; module exports the best option for the target platform with uniform API.
+
+ There are alternative file locking packages:
+
+ * &quot;GHC.IO.Handle.Lock&quot; in @base &gt;= 4.10@ is good enough for most use cases.
+ However, uses only &#39;Handle&#39;s so these locks cannot be used for intra-process locking.
+ (You should use e.g. &#39;MVar&#39; in addition).
+
+ * &lt;https://hackage.haskell.org/package/filelock filelock&gt; doesn&#39;t support OFD locking.
+
+ /Lukko/ means lock in Finnish.
+
+ Submodules &quot;Lukko.OFD&quot;, &quot;Lukko.Windows&quot; etc are available based on following conditions.
+
+ @
+ if os(windows)
+ \ cpp-options: -DHAS_WINDOWS_LOCK
+
+ elif (os(linux) &amp;&amp; flag(ofd-locking))
+ \ cpp-options: -DHAS_OFD_LOCKING
+ \ cpp-options: -DHAS_FLOCK
+
+ elif !(os(solaris) || os(aix))
+ \ cpp-options: -DHAS_FLOCK
+ @
+
+ &quot;Lukko.FLock&quot; is available on not (Windows or Solaris or AIX).
+ &quot;Lukko.NoOp&quot; is always available.
+ </longdescription>
+</pkgmetadata>