summaryrefslogtreecommitdiff
path: root/dev-haskell/logict-state
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-22 14:43:09 +0100
commitc0a9f2400f704c438b0cef4f4105e7bb6c3cbbff (patch)
treef03dacf9fcbf88186d23a1c68620015cca2a06b2 /dev-haskell/logict-state
parent4c4bbf21230bd972cf759b2a40b782aa4149fc1f (diff)
gentoo auto-resync : 22:08:2022 - 14:43:09
Diffstat (limited to 'dev-haskell/logict-state')
-rw-r--r--dev-haskell/logict-state/Manifest4
-rw-r--r--dev-haskell/logict-state/files/logict-state-0.1.0.5-monadfail-compat.patch64
-rw-r--r--dev-haskell/logict-state/logict-state-0.1.0.5.ebuild28
-rw-r--r--dev-haskell/logict-state/metadata.xml14
4 files changed, 0 insertions, 110 deletions
diff --git a/dev-haskell/logict-state/Manifest b/dev-haskell/logict-state/Manifest
deleted file mode 100644
index dc5dd3ceb206..000000000000
--- a/dev-haskell/logict-state/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX logict-state-0.1.0.5-monadfail-compat.patch 2447 BLAKE2B a6decde86f3993e00e55e3298e25347ce2fbd43b38bda91de00b828267c20e8ec53f98c64e7ee4f25a65d44eaf18b462b354b2eca97430779688007bd551228c SHA512 5c237951869ae09b7b1e0c82d39e9d50949ff53dab7afdd51fe081dbed412e29e4c3875e5d446bb81b426e53e158ba9977beaf2abe54b61c412c2fc8c91cf5fb
-DIST logict-state-0.1.0.5.tar.gz 4525 BLAKE2B 9dbd41d4b1f1f9023082836a852bc3f2d273f920db6caa4383fc23c967e588dcb2e94b053a5c7a3fb3c28afbd714f7006583a65dd87c3eb3b535202caf2223fc SHA512 f641907213c23de22a779f1dd065aa3c02de5686dae0fac86403d958ba6d2cba23d86d6a43b8c78fff0963f7ed62837d704243eeac006163eb6fa2ab26fe9ad4
-EBUILD logict-state-0.1.0.5.ebuild 707 BLAKE2B 79c1fb80c5e47f31cda599c061421ac2db65a8e1cf5610855cee329daddb723fb480fae92597ea95d4d4dc1642833925dabcf85d79c1416cbf6e06fb602d42f2 SHA512 5bf998460f9443947b6261acc5ebb8db82c1c78c03a712069a1207193968ce27040dc180c67d16576da115c28fff2ae1799f8713830394570e919673ba5baa05
-MISC metadata.xml 490 BLAKE2B 5bf78cbbcbc88d62520c4289bdb28e7002db8d5f80569a072717cd5f8b6947ea6698161f11fe94e7d1ec2e064322f85413e4cecdcdd369770cf54d84f662157a SHA512 b704c10ceb4c43fe257969ad595c661c177cdb9c838b5fb705fd7a8e60a4c2cccfc35efbcb868e1e23a1599cdeba93c816fb2103806d34600941273a523fadcd
diff --git a/dev-haskell/logict-state/files/logict-state-0.1.0.5-monadfail-compat.patch b/dev-haskell/logict-state/files/logict-state-0.1.0.5-monadfail-compat.patch
deleted file mode 100644
index 3da6f26e0dd4..000000000000
--- a/dev-haskell/logict-state/files/logict-state-0.1.0.5-monadfail-compat.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff --git a/src/Control/Monad/LogicState.hs b/src/Control/Monad/LogicState.hs
-index 93be8aa..613a77c 100644
---- a/src/Control/Monad/LogicState.hs
-+++ b/src/Control/Monad/LogicState.hs
-@@ -1,4 +1,4 @@
--{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, FlexibleContexts, GADTs, ScopedTypeVariables, FunctionalDependencies #-}
-+{-# LANGUAGE UndecidableInstances, Rank2Types, FlexibleInstances, FlexibleContexts, GADTs, ScopedTypeVariables, FunctionalDependencies, CPP #-}
-
- -------------------------------------------------------------------------
- -- |
-@@ -39,6 +39,9 @@ import Control.Applicative
-
- import Control.Monad
- import Control.Monad.Identity
-+#if !MIN_VERSION_base(4,11,0)
-+import qualified Control.Monad.Fail as Fail
-+#endif
- import Control.Monad.Trans
-
- import Control.Monad.State
-@@ -83,7 +86,12 @@ instance Applicative (LogicStateT gs bs f) where
- instance Monad (LogicStateT gs bs m) where
- return a = LogicStateT ($ a)
- m >>= f = LogicStateT $ \sk -> unLogicStateT m (\a -> unLogicStateT (f a) sk)
-- fail _ = LogicStateT $ flip const
-+#if !MIN_VERSION_base(4,11,0)
-+ fail = Fail.fail
-+#endif
-+
-+instance MonadFail (LogicStateT gs bs m) where
-+ fail _ = LogicStateT $ flip const
-
- instance Alternative (LogicStateT gs bs f) where
- empty = LogicStateT $ flip const
-diff --git a/src/Control/Monad/TransLogicState/Class.hs b/src/Control/Monad/TransLogicState/Class.hs
-index 4fa61c4..267704a 100644
---- a/src/Control/Monad/TransLogicState/Class.hs
-+++ b/src/Control/Monad/TransLogicState/Class.hs
-@@ -1,4 +1,4 @@
--{-# LANGUAGE ScopedTypeVariables #-}
-+{-# LANGUAGE ScopedTypeVariables, CPP #-}
-
- module Control.Monad.TransLogicState.Class
- ( TransLogicState(..)
-@@ -15,12 +15,19 @@ import Control.Arrow
- import Control.Monad.Identity
- -- import Control.Monad.Trans
-
-+instance MonadFail Identity where
-+ fail msg = runIdentity $ fail msg
-+
- -- | Additions to MonadTrans specifically useful for LogicState
- class {- MonadTrans t => -} TransLogicState s t where
- -------------------------------------------------------------------------
- -- | Extracts the first result from a 't m' computation,
- -- failing otherwise.
-+#if !MIN_VERSION_base(4,13,0)
- observeT :: (Monad m) => s -> t m a -> m a
-+#else
-+ observeT :: (MonadFail m) => s -> t m a -> m a
-+#endif
- observeT e m = fmap head $ observeManyT e 1 m
-
- -------------------------------------------------------------------------
diff --git a/dev-haskell/logict-state/logict-state-0.1.0.5.ebuild b/dev-haskell/logict-state/logict-state-0.1.0.5.ebuild
deleted file mode 100644
index 519433782076..000000000000
--- a/dev-haskell/logict-state/logict-state-0.1.0.5.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.5.6.9999
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour"
-inherit haskell-cabal
-
-DESCRIPTION="Library for logic programming based on haskell package logict"
-HOMEPAGE="https://github.com/atzedijkstra/logict-state"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-haskell/logict-0.6.0.2:=[profile?]
- >=dev-haskell/mtl-2.1:=[profile?]
- >=dev-lang/ghc-7.10.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.22.2.0
-"
-
-PATCHES=( "${FILESDIR}"/${P}-monadfail-compat.patch )
diff --git a/dev-haskell/logict-state/metadata.xml b/dev-haskell/logict-state/metadata.xml
deleted file mode 100644
index 2ccb8fdaf1f1..000000000000
--- a/dev-haskell/logict-state/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- <name>Gentoo Haskell</name>
- </maintainer>
- <longdescription>
- Logic programming built on top of part of logict library, in particular for dealing with backtrackable state
- </longdescription>
- <upstream>
- <remote-id type="github">atzedijkstra/logict-state</remote-id>
- </upstream>
-</pkgmetadata>