summaryrefslogtreecommitdiff
path: root/dev-haskell/http-date
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/http-date
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/http-date')
-rw-r--r--dev-haskell/http-date/Manifest4
-rw-r--r--dev-haskell/http-date/http-date-0.0.11.ebuild29
-rw-r--r--dev-haskell/http-date/http-date-0.0.8.ebuild2
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-haskell/http-date/Manifest b/dev-haskell/http-date/Manifest
index 1f5740f1f976..44698cec7b21 100644
--- a/dev-haskell/http-date/Manifest
+++ b/dev-haskell/http-date/Manifest
@@ -1,3 +1,5 @@
+DIST http-date-0.0.11.tar.gz 5351 BLAKE2B e9f9ff3323895ea90fd98625af7fb5213d52303e2b39a661617d7635db294ec256470d6b4dc6d6c38fc2dc7f349eb3a9d4018358e7fef43b966539229ef779fe SHA512 dec4f4fc5f765887fb884a0309648dd3336e2591c05ac89150c7ebe935d1167f3c5996a12c5371f3fab3525b95ca8e46873b6bafc1b937b1b5367c256358a62d
DIST http-date-0.0.8.tar.gz 5322 BLAKE2B a88ee8ff31e5356aefa095d5c700e77554657a1102ab12091debbe173dc8b8886b3468795117b81ac745c08511b5b856ee49f6754db265226bd375926a68413c SHA512 7ad48dc20c62fea21aad0d15251cca333b56a59ca13c45be61fd9fcd938e28f5cb82701b7a394c256e1487679d0bbfcf994de90d7c8b57888e3bac8809e97114
-EBUILD http-date-0.0.8.ebuild 805 BLAKE2B abfd7ff27ff207cb07b5308864e4931e7d27a4ef340d75905918a5d7e2e67e2c49575654a9da1729b820dc49e4334397db59a2d9db54be4697003a5a85e75587 SHA512 ce16d222ca65e1c4a556dc4e268fb160d2caa89561224fd4f06e5945bf4aa3cf54f7aace2a62e6172688da671486b04ec2dcfec3c8ce1c3936827b7c6a5dc1ff
+EBUILD http-date-0.0.11.ebuild 804 BLAKE2B 7587996d6f5408635b1997cfdb130fbf1f1117ff6ebbb64f9109b063dba836a1eb73521fdf3b41d9938b845c864e5076fd6d9df4938bacf58ce768c01f860257 SHA512 80ea557428d2d042d653f38c5dc17a0e5aaf5657318c52f03c40e1e61f1ef964874172d42079ac2049bbaddd72c279f9392e8859f9c58a04c0728e62369a03f9
+EBUILD http-date-0.0.8.ebuild 805 BLAKE2B b3ba01309f14c4fa06cfe70de7602204f51cbfc629dadd8f2fc6cfabec1a9201b6352dc5bcc25f6e154bd3935d35d11c5cac56de55005ce49603c7ad49d88aed SHA512 91fd2174f08987d2553a370d4ed5c5ecb42b41ef24dc3bdf192d8b9ac5824c585fa9d9cd338d5e85f4faf2abecbe0fd82873c28a28ec4405199a6033c231074e
MISC metadata.xml 250 BLAKE2B 3adf9597d5114c480b4cc9fb5c3e231d8475b795cd6dce77986e13583ab6e59b43857cf2328570490abef0062a8b8a6b73d231867f9b62124855515cdc044d6d SHA512 5ef2c1d34a3438b39a38c041d45bb06bd0f1ae8a3f8b971bd5aaf36dee560f380e9abefab0c2a4cd7b518e151f5c6a0d0c7cd53caee9a384818f1bdc7deeadc4
diff --git a/dev-haskell/http-date/http-date-0.0.11.ebuild b/dev-haskell/http-date/http-date-0.0.11.ebuild
new file mode 100644
index 000000000000..bd0d30401b3e
--- /dev/null
+++ b/dev-haskell/http-date/http-date-0.0.11.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP Date parser/formatter"
+HOMEPAGE="https://hackage.haskell.org/package/http-date"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RESTRICT=test # Ambiguous module name ‘Data.Time’: it was found in multiple packages: pulseaudio-0.0.2.1 time-1.8.0.2
+
+RDEPEND="dev-haskell/attoparsec:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/old-locale )
+"
diff --git a/dev-haskell/http-date/http-date-0.0.8.ebuild b/dev-haskell/http-date/http-date-0.0.8.ebuild
index 6ddd73edf8e5..ce23a21ec32c 100644
--- a/dev-haskell/http-date/http-date-0.0.8.ebuild
+++ b/dev-haskell/http-date/http-date-0.0.8.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# ebuild generated by hackport 0.6.9999