summaryrefslogtreecommitdiff
path: root/dev-haskell/http-attoparsec
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/http-attoparsec
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/http-attoparsec')
-rw-r--r--dev-haskell/http-attoparsec/Manifest5
-rw-r--r--dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch9
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild31
-rw-r--r--dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r3.ebuild34
-rw-r--r--dev-haskell/http-attoparsec/metadata.xml14
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-haskell/http-attoparsec/Manifest b/dev-haskell/http-attoparsec/Manifest
new file mode 100644
index 000000000000..a26aaf01b357
--- /dev/null
+++ b/dev-haskell/http-attoparsec/Manifest
@@ -0,0 +1,5 @@
+AUX http-attoparsec-0.1.1-http.patch 314 BLAKE2B 3af42442fa504726c5eacaf7686448611c22ef4ea6e8908f06e54a5bedd8969bf0d69598865d758027116d034ee9012d78baf331c3c51a728f337e780ea8bf2f SHA512 bb52b574df35cf76b0269a216d8d11cb04dafeba88a7f0d0581a0296e49d8eb125038a431174618964d3afa76c50b9eb5315101648ce8a2564e4ea685445620c
+DIST http-attoparsec-0.1.1.tar.gz 2501 BLAKE2B ffd8cfdcd7bf8b5916348633d519531a3a50426a03d9aef2818ebc3577c30f54e2e3c9ff1a4e7cfa7ea8cbe48a08c97262a796fead873128eb70d3074807a994 SHA512 7be64a4f8df874b392b3d75ecb16bb4e4f689e2c9e65eb406c7287bd637eced2c2580d27be3cfa164aac9cdfdd89cb8aaa8d9ab708e44542a478ec76a9b5955d
+EBUILD http-attoparsec-0.1.1-r2.ebuild 780 BLAKE2B bb68a5dcbeee2987961668bdf331f1c8e506ee8ad21f89f00ba36679dce9a257af8bccfe97f1c3a153b205d69cea3d6eff162005feaa7ca151e0828d5e1826d4 SHA512 f8f084fd72e06f8ee226434cf0cc8663b76edada42c8ac974f3bee04a6249c5e4a127e306d8bdb131073209a9f5be330ce7b0980a6167640ac686e34b750d45b
+EBUILD http-attoparsec-0.1.1-r3.ebuild 838 BLAKE2B eeff3f02692bd75885810e5d7a44185368662dee2bdeeab1267bc1a00f88306e814efec60d820363c9d8839b1fabc75da4d10f71f71e79f9c2c6ab379d0ee8e2 SHA512 97701d2125e03196bf62991d367bd861bde8eb2539e0b7d62917e8c5bdee898884223b79b83b986899c14e579af75fa5c10d65cfd8e126d34f854a9d2d977978
+MISC metadata.xml 415 BLAKE2B 71fc9526cf2479451dc041043f4438985998615205db06bc7f7e6c2d726b68bf4506c42c222fe075ed07269469a994174bfeb224361217ab27243f1bee05922b SHA512 9e100f10d0b808f50bdada4a11e37cf273d7471054d26aeffafb4c1c5a4528750610179117a94b350222322ff6b983daa70f877c4bdc22aef177ff5816823a9a
diff --git a/dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch b/dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch
new file mode 100644
index 000000000000..2de100c5deb5
--- /dev/null
+++ b/dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch
@@ -0,0 +1,9 @@
+diff --git a/Network/HTTP/Attoparsec.hs b/Network/HTTP/Attoparsec.hs
+index ec464d0..37f9983 100644
+--- a/Network/HTTP/Attoparsec.hs
++++ b/Network/HTTP/Attoparsec.hs
+@@ -7,3 +7,3 @@ module Network.HTTP.Attoparsec
+ where
+-import Network.HTTP.Types.Header
++import Network.HTTP.Types.Header hiding (parseByteRanges)
+
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..4ea20efa90de
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?] <dev-haskell/http-types-0.9:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'attoparsec >= 0.10.4.0 && < 0.12' 'attoparsec >= 0.10.4.0'
+}
diff --git a/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r3.ebuild b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..2dcf768bf7ed
--- /dev/null
+++ b/dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Attoparsec parsers for http-types"
+HOMEPAGE="https://github.com/tlaitinen/http-attoparsec"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.4.0:=[profile?]
+ >=dev-haskell/http-types-0.8.0:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-http.patch
+
+ cabal_chdeps \
+ 'attoparsec >= 0.10.4.0 && < 0.12' 'attoparsec >= 0.10.4.0' \
+ 'http-types >= 0.8.0 && < 0.9' 'http-types >= 0.8.0'
+}
diff --git a/dev-haskell/http-attoparsec/metadata.xml b/dev-haskell/http-attoparsec/metadata.xml
new file mode 100644
index 000000000000..218272ffd685
--- /dev/null
+++ b/dev-haskell/http-attoparsec/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Attoparsec parsers for http-types.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tlaitinen/http-attoparsec</remote-id>
+ </upstream>
+</pkgmetadata>