summaryrefslogtreecommitdiff
path: root/dev-haskell/htf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/htf
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/htf')
-rw-r--r--dev-haskell/htf/Manifest5
-rw-r--r--dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch9
-rw-r--r--dev-haskell/htf/htf-0.13.1.0.ebuild52
-rw-r--r--dev-haskell/htf/metadata.xml23
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-haskell/htf/Manifest b/dev-haskell/htf/Manifest
new file mode 100644
index 000000000000..70e85ffe87ea
--- /dev/null
+++ b/dev-haskell/htf/Manifest
@@ -0,0 +1,5 @@
+AUX htf-0.13.1.0-aeson-pretty-0.8.patch 352 SHA256 655828f8f04747d4a6b6c627b07ac6759aa88802040956dc86356fd3a7d1ff5e SHA512 31f927eeccab5037ec3394a2a608b434e43fa9c3bfd0a0d4bd6662add7abbb259986ed0ef1a84c31d2e84b68cdb6e3d6133e5bed34331b81cb7b3fc61fa8e8d8 WHIRLPOOL ba91431b264ba33916419fec6769e145af2cf4d793b2dc1e1e4dbbaaaca1a44c77bdf1018bdd0f5cafc52ab8e671ef977280903111ce020039d0ebaf7d0eaab1
+DIST HTF-0.13.1.0.tar.gz 78310 SHA256 1cb469ee21766fb7ad56fb42469709fac06214f7a33c39880134dfc2ea0de847 SHA512 1292f8f0b9189e1ce05de1cf6f686ce77a839c4191a5f8b8000c8d740abe4b8f457a7c5ed8aadc13221fe9fde9b4c15bde9f9f6f53ac03178cd1884572fb4069 WHIRLPOOL 76f85fc1710d598ac38bb7849467536af705d9ab82811745212c28ae0a2e5c8fac588320e30f3c44b173665dfb60089c37610ac669f075bf6ef74f255508baff
+EBUILD htf-0.13.1.0.ebuild 1421 SHA256 06e56d987f651f65724408214a5c57d96460bc7a9ef8e8052d7e017508967a31 SHA512 b4254f185765e75a289d4856efe1eb8abbb5d6ec7d939cb1cac7385934736749a9748afa282ad788b09e88beaa0f75cf15852a9e42d40ac0b29a1d9cc884ccde WHIRLPOOL b847074cd955c3e6cef3a5cf229e9c92153f50c32020352f990f01bac31b5d78588ebb7c207a67f031ab9ea5887b8769b91c248c33d2ccebcbcaf694772526f1
+MISC ChangeLog 398 SHA256 cd9666a1ee98e1643805eb4ef95ee555fd46d1cfef56bf424331a3ae43563290 SHA512 d1996b2b4410fa9fe046f738e3b0eae6355d17261307f91ff8dc54e796a042377d2d353a8617b9b63714442690936e6b271b038501e99205d4453dd112f07575 WHIRLPOOL 5cd23be8fc6955cadbfcfb190509f89bb56650520aaff38f44a2e4443cb7b31f473aa72b39aa7c76654f9a3100b0651315ecfeeb3ed8f985782489a35dc0dc5c
+MISC metadata.xml 923 SHA256 df19ab2db950e84b0a5d0f2016741109406a165ceb7918e7d19b4e0fe671d45d SHA512 1bcdd3551b19f09f600b050f84ab81de6e99133b29a8a94942ff068ef354a9bb31226395cb221c416a65466a96973a92521d3aa3b13c94b557bdedf011e28164 WHIRLPOOL 6a88ae47b16f19efed698a141d806ef88f7b017b0f8c978e9c877d81bc8bb51bc0334e9dd8dcb1a80eb88277bc2b67ae3d1bc73ac33fda7b41a2a2fb087d3afc
diff --git a/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch b/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch
new file mode 100644
index 000000000000..ac1472051eba
--- /dev/null
+++ b/dev-haskell/htf/files/htf-0.13.1.0-aeson-pretty-0.8.patch
@@ -0,0 +1,9 @@
+diff --git a/tests/TestHTF.hs b/tests/TestHTF.hs
+index 4a71874..c0442a5 100644
+--- a/tests/TestHTF.hs
++++ b/tests/TestHTF.hs
+@@ -383,3 +383,3 @@ checkOutput output =
+ BSL.toStrict $
+- J.encodePretty' (J.Config 2 J.compare) json
++ J.encodePretty' (J.defConfig { J.confIndent = J.Spaces 2, J.confCompare = J.compare }) json
+
diff --git a/dev-haskell/htf/htf-0.13.1.0.ebuild b/dev-haskell/htf/htf-0.13.1.0.ebuild
new file mode 100644
index 000000000000..764b01df66c6
--- /dev/null
+++ b/dev-haskell/htf/htf-0.13.1.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTF"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The Haskell Test Framework"
+HOMEPAGE="https://github.com/skogsbaer/HTF/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ >=dev-haskell/cpphs-1.19:=[profile?]
+ >=dev-haskell/diff-0.3:=[profile?]
+ dev-haskell/haskell-src:=[profile?]
+ >=dev-haskell/hunit-1.2.5:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-1.1:=[profile?]
+ >=dev-haskell/old-time-1.0:=[profile?]
+ >=dev-haskell/quickcheck-2.3:2=[profile?]
+ >=dev-haskell/random-1.0:=[profile?]
+ >=dev-haskell/regex-compat-0.92:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-haskell/xmlgen-0.6:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/aeson-pretty
+ >=dev-haskell/temporary-1.1
+ >=dev-haskell/unordered-containers-0.2 )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-aeson-pretty-0.8.patch
+}
diff --git a/dev-haskell/htf/metadata.xml b/dev-haskell/htf/metadata.xml
new file mode 100644
index 000000000000..be697624296d
--- /dev/null
+++ b/dev-haskell/htf/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ The Haskell Test Framework (/HTF/ for short) lets you define unit
+ tests (&lt;http://hunit.sourceforge.net&gt;), QuickCheck properties
+ (&lt;http://www.cs.chalmers.se/~rjmh/QuickCheck/&gt;), and black box
+ tests in an easy and convenient way. The HTF uses a custom
+ preprocessor that collects test definitions automatically.
+ Furthermore, the preprocessor allows the HTF to report failing
+ test cases with exact file name and line number information.
+
+ The documentation of the "Test.Framework.Tutorial" module
+ provides a tutorial for the HTF.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">skogsbaer/HTF</remote-id>
+ </upstream>
+</pkgmetadata>