summaryrefslogtreecommitdiff
path: root/dev-haskell/hsyaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/hsyaml
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/hsyaml')
-rw-r--r--dev-haskell/hsyaml/Manifest3
-rw-r--r--dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild46
-rw-r--r--dev-haskell/hsyaml/metadata.xml21
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-haskell/hsyaml/Manifest b/dev-haskell/hsyaml/Manifest
new file mode 100644
index 000000000000..978d1ae00f17
--- /dev/null
+++ b/dev-haskell/hsyaml/Manifest
@@ -0,0 +1,3 @@
+DIST HsYAML-0.2.1.0.tar.gz 83976 BLAKE2B fff32d30eb6cb76c852c9cb1909b8be06e4818d23322397271594dfe60895ea79ffa8cc4c4944173de30d46e1ef8a2872972434aeacec44fff8d52dc169264e5 SHA512 f8ad41a99e48183835093ad8bf6a3fbdf4b9ad9df3bea46b12efd55a9555c22bd2595c72b1ac2e73379ab47e21f6cbf9022412db8971e1c7c02a32e824f53304
+EBUILD hsyaml-0.2.1.0.ebuild 1342 BLAKE2B 6f7257268c6ad56894b24d0f57a59bea526258f2e4b19e0c5ae57d8c697a930e087c6775e136d091b6b965166fb57ec23c4a0198f603d3872cd9050fdbd3b1a0 SHA512 e3074431b4c0a2582da9a738d0273f6c51242979ff069f28b06fbe81a93cf394f4d8bda5b7cc03c84acd340255d82bd5169fa52e721fdf39705f768843899b86
+MISC metadata.xml 1257 BLAKE2B 6517367f3e13c4ad4d47af8ed098b9aa0a53d38150ec5777fe63197c0e0f5f03bdbe4154aee763735c72c5bd407559d1b9e1af1231acdcb65de7d75efd0c1764 SHA512 c070e085bc7682ce4b2f6abb37a9804898e81e10228573f975a33e0dad6101b834ab7a873f8cc1b04884fe64f322c59024b210af79de5d9aad4a4980c5de7aba
diff --git a/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
new file mode 100644
index 000000000000..756bb6481b97
--- /dev/null
+++ b/dev-haskell/hsyaml/hsyaml-0.2.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HsYAML"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Pure Haskell YAML 1.2 parser"
+HOMEPAGE="https://github.com/hvr/HsYAML"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/fail-4.9.0.0:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/mtl-2.2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/nats-1.1.2:=[profile?] <dev-haskell/nats-1.2:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/text-1.2.3:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14
+ test? ( >=dev-haskell/quickcheck-2.13:2=
+ >=dev-haskell/tasty-1.2:=
+ >=dev-haskell/tasty-quickcheck-0.10:= )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.5 && <4.14' 'base >=4.5' \
+ 'containers >=0.4.2 && <0.7' 'containers >=0.4.2' \
+ 'QuickCheck == 2.13.*' 'QuickCheck >= 2.13' \
+ 'tasty == 1.2.*' 'tasty >= 1.2' \
+ 'tasty-quickcheck == 0.10.*' 'tasty-quickcheck >= 0.10'
+}
diff --git a/dev-haskell/hsyaml/metadata.xml b/dev-haskell/hsyaml/metadata.xml
new file mode 100644
index 000000000000..4fd3981c32d1
--- /dev/null
+++ b/dev-haskell/hsyaml/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ @HsYAML@ is a [YAML 1.2](http://yaml.org/spec/1.2/spec.html) parser implementation for Haskell.
+
+ Features of @HsYAML@ include:
+
+ * Pure Haskell implementation with small dependency footprint and emphasis on strict compliance with the [YAML 1.2 specification](http://yaml.org/spec/1.2/spec.html).
+ * Direct decoding to native Haskell types via (@aeson@-inspired) typeclass-based API (see &quot;Data.YAML&quot;).
+ * Support for constructing custom YAML node graph representation (including support for cyclic YAML data structures).
+ * Support for the standard (untyped) /Failsafe/, (strict) /JSON/, and (flexible) /Core/ \&quot;schemas\&quot; providing implicit typing rules as defined in the YAML 1.2 specification (including support for user-defined custom schemas).
+ * Event-based API resembling LibYAML&#39;s Event-based API (see &quot;Data.YAML.Event&quot;).
+ * Low-level API access to lexical token-based scanner (see &quot;Data.YAML.Token&quot;).
+
+ </longdescription>
+</pkgmetadata>