summaryrefslogtreecommitdiff
path: root/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hsql/hsql-1.8.2-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hsql/hsql-1.8.2-r1.ebuild')
-rw-r--r--dev-haskell/hsql/hsql-1.8.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/hsql/hsql-1.8.2-r1.ebuild b/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
new file mode 100644
index 000000000000..7a23c081fb5a
--- /dev/null
+++ b/dev-haskell/hsql/hsql-1.8.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Database access from Haskell"
+HOMEPAGE="http://hackage.haskell.org/package/hsql"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/old-time:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+pkg_postinst () {
+ ghc-package_pkg_postinst
+
+ elog "You will probably want to emerge one or more HSQL backend."
+ elog "These backends are available:"
+ elog " hsql-postgresql"
+ elog " hsql-mysql"
+ elog " hsql-sqlite"
+ elog " hsql-odbc"
+}