summaryrefslogtreecommitdiff
path: root/dev-haskell/hourglass
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hourglass
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hourglass')
-rw-r--r--dev-haskell/hourglass/Manifest3
-rw-r--r--dev-haskell/hourglass/hourglass-0.2.9.ebuild29
-rw-r--r--dev-haskell/hourglass/metadata.xml19
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/hourglass/Manifest b/dev-haskell/hourglass/Manifest
new file mode 100644
index 000000000000..5c825db07ad5
--- /dev/null
+++ b/dev-haskell/hourglass/Manifest
@@ -0,0 +1,3 @@
+DIST hourglass-0.2.9.tar.gz 24919 BLAKE2B f4b1332a72a887c3c72eaf41086059a6156a609e3386d66a475191ef5d864fb53499b05713deec751f991f110e24d0dce51de1314cc846a145b356c18cee613b SHA512 ba6ee78b900139e8267a4bd9676abc2189e6c581225c5718c6f753515b1b7037ee4f8197f6910cc8ef769110234ec1cef7b3af0d1c6c7cef93bd87c81c7f57d4
+EBUILD hourglass-0.2.9.ebuild 690 BLAKE2B 2732a843fe54dba84a390bfa9694c49aaeefc51f0bc89610b90bc197a3d3550c7e6e164455463cbe0857c82052275f06290c0402a7b58d04dd84b159d79a31f6 SHA512 b1df6de18cce13c6ae8db898b43bdf28014baa22bb09e015e4bf5997d1a92b2a8246e248df334004994af3141d81d47c620e8bbae9445932d06da2750d1e079f
+MISC metadata.xml 660 BLAKE2B fc66061dbbb891e1eb7e7d18e218a302cf98da733dc943e19740324c9be32124af9c1facb4a3a50ba388b7e4f3c17058d254b6e6acea70821fcca153d2dd9538 SHA512 e7158ee20ead18c600918b0b5051e4e8ec3dafec9829007a065d4d7ee9114eff48ae14895eaae3b654e12466dcda884c27c4f39b026ca231e3078eaf2858b603
diff --git a/dev-haskell/hourglass/hourglass-0.2.9.ebuild b/dev-haskell/hourglass/hourglass-0.2.9.ebuild
new file mode 100644
index 000000000000..d7d1242d5cba
--- /dev/null
+++ b/dev-haskell/hourglass/hourglass-0.2.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="simple performant time related library"
+HOMEPAGE="https://github.com/vincenthz/hs-hourglass"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/mtl
+ dev-haskell/old-locale
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck )
+"
diff --git a/dev-haskell/hourglass/metadata.xml b/dev-haskell/hourglass/metadata.xml
new file mode 100644
index 000000000000..aeb2e0a19f66
--- /dev/null
+++ b/dev-haskell/hourglass/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Simple time library focusing on simple but powerful and performant API
+
+ The backbone of the library are the Timeable and Time type classes.
+
+ Each Timeable instances can be converted to type that has a Time instances,
+ and thus are different representations of current time.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-hourglass</remote-id>
+ </upstream>
+</pkgmetadata>