summaryrefslogtreecommitdiff
path: root/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild')
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
new file mode 100644
index 000000000000..6c914b777c5c
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="https://github.com/jgm/highlighting-kate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2:=[profile?]
+ <dev-haskell/blaze-html-0.7:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ pcre-light? ( =dev-haskell/pcre-light-0.4*:=[profile?]
+ )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin:=[profile?]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag pcre-light pcre-light)
+}