summaryrefslogtreecommitdiff
path: root/dev-haskell/hashtables/hashtables-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/hashtables/hashtables-1.3.1.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/hashtables/hashtables-1.3.1.ebuild')
-rw-r--r--dev-haskell/hashtables/hashtables-1.3.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/hashtables/hashtables-1.3.1.ebuild b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
new file mode 100644
index 000000000000..13d8df830c14
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.3.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: sse42:cpu_flags_x86_sse4_2,+unsafe-tricks,-portable
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="https://github.com/gregorycollins/hashtables"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bounds-checking cpu_flags_x86_sse4_2 debug detailed-profiling"
+
+RDEPEND="
+ =dev-haskell/hashable-1.4*:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.14
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/mwc-random-0.8 <dev-haskell/mwc-random-0.16
+ >=dev-haskell/quickcheck-2.3.0.2
+ >=dev-haskell/test-framework-0.3.1 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.6 <dev-haskell/test-framework-hunit-3
+ >=dev-haskell/test-framework-quickcheck2-0.2.6 <dev-haskell/test-framework-quickcheck2-0.4
+ )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag bounds-checking bounds-checking) \
+ $(cabal_flag debug debug) \
+ $(cabal_flag detailed-profiling detailed-profiling) \
+ --flag=-portable \
+ $(cabal_flag cpu_flags_x86_sse4_2 sse42) \
+ --flag=unsafe-tricks
+}