summaryrefslogtreecommitdiff
path: root/dev-haskell/happy/happy-1.19.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-haskell/happy/happy-1.19.12.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-haskell/happy/happy-1.19.12.ebuild')
-rw-r--r--dev-haskell/happy/happy-1.19.12.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/happy/happy-1.19.12.ebuild b/dev-haskell/happy/happy-1.19.12.ebuild
new file mode 100644
index 000000000000..cfeff40b81cd
--- /dev/null
+++ b/dev-haskell/happy/happy-1.19.12.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: +small_base
+
+CABAL_FEATURES="test-suite"
+inherit haskell-cabal autotools
+
+DESCRIPTION="Happy is a parser generator for Haskell"
+HOMEPAGE="https://www.haskell.org/happy/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-haskell/mtl-2.2.1:=
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ doc? ( ~app-text/docbook-xml-dtd-4.2
+ app-text/docbook-xsl-stylesheets )
+"
+
+src_prepare() {
+ default
+
+ if use doc; then
+ cd doc || die
+ eautoconf
+ fi
+}
+
+src_configure() {
+ # '--with-happy=false' allows detecting circular
+ # depends even when 'happy' is installed in system
+ haskell-cabal_src_configure \
+ --with-happy=false\
+ --flag=small_base
+
+ if use doc; then
+ # does not like out-of-source builds
+ cd doc || die
+ econf
+ fi
+}
+
+src_compile() {
+ haskell-cabal_src_compile
+
+ if use doc; then
+ emake -C doc -j1
+ fi
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/happy/.
+ doman doc/happy.1
+ fi
+}