summaryrefslogtreecommitdiff
path: root/dev-haskell/hackage-security
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/hackage-security
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/hackage-security')
-rw-r--r--dev-haskell/hackage-security/Manifest3
-rw-r--r--dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild56
-rw-r--r--dev-haskell/hackage-security/metadata.xml35
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-haskell/hackage-security/Manifest b/dev-haskell/hackage-security/Manifest
new file mode 100644
index 000000000000..5dc442226a00
--- /dev/null
+++ b/dev-haskell/hackage-security/Manifest
@@ -0,0 +1,3 @@
+DIST hackage-security-0.5.2.2.tar.gz 83131 BLAKE2B 4ce0ff3d4ee2647ac5311996756ce43aa91ee7989ef6a46ea94679890900811c770e5ce91acc0e39fe0e42767cdd6d21bb11bee7d385c9e3a30c642b9471f423 SHA512 5adab3c46d7aada8668128ad8c9389ca65489eec776f8571b8ee5834d74b961f19b558cb6642cbb1891ee381b2d4f2019dddf29bad13607fe23bef49a3d6f535
+EBUILD hackage-security-0.5.2.2.ebuild 2038 BLAKE2B 294b63a27ee629b40cfb90336a0a2b6998f7a1c1912c9b666dc2c839b0cef1fd4bb21d97b842ccba3324a0b8a4526d1a1f2c2b7abbef9cd8a1081d8f97b51117 SHA512 9fe48f4bd94367d286ec50d4b71a9fa97e6ce5a4f68026e92cb629b824bf64ccb674d8cdec99433d21d70aa1e284e2c85ab63f22489b783ae515bba682b0f342
+MISC metadata.xml 1351 BLAKE2B c2977bbb8e8b408a51025c61970fe9881207ca2c91e5b7c7778a6c46caa15314c3536b2c720370c7739d37ca38c3f1693bd4c6ad024a5eaede982cd5940e0c07 SHA512 bc2b65083d43a010a500ee5d47300703dec5a0b1bd4490ad8a64a35063e15bf198124aa049eb895c3c42dfd021720d32b7c73eddbbabb105d5e851b24e78cf46
diff --git a/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild b/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild
new file mode 100644
index 000000000000..7690bc1904e0
--- /dev/null
+++ b/dev-haskell/hackage-security/hackage-security-0.5.2.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Hackage security library"
+HOMEPAGE="https://github.com/well-typed/hackage-security"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE="+use-network-uri"
+
+RDEPEND=">=dev-haskell/base16-bytestring-0.1.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/cabal-1.14:=[profile?] <dev-haskell/cabal-1.26:=[profile?]
+ >=dev-haskell/cryptohash-sha256-0.11:=[profile?] <dev-haskell/cryptohash-sha256-0.12:=[profile?]
+ >=dev-haskell/ed25519-0.0:=[profile?] <dev-haskell/ed25519-0.1:=[profile?]
+ >=dev-haskell/mtl-2.2:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/tar-0.5:=[profile?] <dev-haskell/tar-0.6:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?] <dev-haskell/zlib-0.7:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+ >=dev-haskell/old-locale-1.0:=[profile?]
+ use-network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
+ >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
+ !use-network-uri? ( >=dev-haskell/network-2.5:=[profile?] <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/tasty
+ dev-haskell/tasty-hunit
+ dev-haskell/tasty-quickcheck
+ dev-haskell/temporary
+ !use-network-uri? ( dev-haskell/network-uri ) )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'directory >= 1.1.0.2 && < 1.3' 'directory >= 1.1.0.2'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag use-network-uri use-network-uri)
+}
diff --git a/dev-haskell/hackage-security/metadata.xml b/dev-haskell/hackage-security/metadata.xml
new file mode 100644
index 000000000000..a3594f6cd4ae
--- /dev/null
+++ b/dev-haskell/hackage-security/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="use-network-uri">Get Network.URI from the network-uri package.</flag>
+ </use>
+ <longdescription>
+ The hackage security library provides both server and
+ client utilities for securing the Hackage package server
+ (&lt;http://hackage.haskell.org/&gt;). It is based on The Update
+ Framework (&lt;http://theupdateframework.com/&gt;), a set of
+ recommendations developed by security researchers at
+ various universities in the US as well as developers on the
+ Tor project (&lt;https://www.torproject.org/&gt;).
+
+ The current implementation supports only index signing,
+ thereby enabling untrusted mirrors. It does not yet provide
+ facilities for author package signing.
+
+ The library has two main entry points:
+ "Hackage.Security.Client" is the main entry point for
+ clients (the typical example being @cabal@), and
+ "Hackage.Security.Server" is the main entry point for
+ servers (the typical example being @hackage-server@).
+
+ This is a beta release.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">well-typed/hackage-security</remote-id>
+ </upstream>
+</pkgmetadata>