summaryrefslogtreecommitdiff
path: root/dev-haskell/ghc-paths
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/ghc-paths
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/ghc-paths')
-rw-r--r--dev-haskell/ghc-paths/Manifest3
-rw-r--r--dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild46
-rw-r--r--dev-haskell/ghc-paths/metadata.xml7
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-haskell/ghc-paths/Manifest b/dev-haskell/ghc-paths/Manifest
new file mode 100644
index 000000000000..b3ad848089d4
--- /dev/null
+++ b/dev-haskell/ghc-paths/Manifest
@@ -0,0 +1,3 @@
+DIST ghc-paths-0.1.0.9.tar.gz 2402 BLAKE2B ba84e058a09fabe4b386120855966daeef0d71e0ccc4f131cacdd12cfe064c415715ef3dcbc33a1c5f0e5339f58d61b37d8842c2ca0f97245f56926716bf834b SHA512 0aa38add4a6f27ced115d769603f98eff6fe3e8b60a6477f4b1e669031cbb6408b87d2fed023d790169b623b9cb2b7983871a9bf9d5cfcc298774a34808e2094
+EBUILD ghc-paths-0.1.0.9.ebuild 1417 BLAKE2B 8550d681b8e6e0df74df22e3ee40bcb72dc0eea5a7202609c78a7cbead6f99221cf59a2c9a65458d3ddccfcbe34f6fd2166fb53d45ec1999b45572fc08020ddf SHA512 28cde9a8638588d65028218fbbab3a552073c530101731f10d8a1d750e534d43854d530f2ecc77a26a77407a7f1a861e420bfa50ad2a0d977e3e7da172bd6f25
+MISC metadata.xml 217 BLAKE2B 41b11b7399431ee96c40a11373f20b12940ed7bb1fc77b1619212b2a57a3b34b11b77838d4ac51c1ddb80caab1030224e28567836e5d0a17b4ea6bd1afa2523c SHA512 63f267082f4ba17f6a1226d1c5a14d85d17e0f7a84857605933418d875d09cfffe2a0ca304b8a171dcae59169330fcc3cfca9d6f4c9ce24d135f1125a6d06c70
diff --git a/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
new file mode 100644
index 000000000000..f1330e2e1f62
--- /dev/null
+++ b/dev-haskell/ghc-paths/ghc-paths-0.1.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# haddock feature is explicitely disabled, as this library can be used as haddock depend
+CABAL_FEATURES="lib profile"
+inherit haskell-cabal
+
+DESCRIPTION="Knowledge of GHC's installation directories"
+HOMEPAGE="http://hackage.haskell.org/package/ghc-paths"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.8.2:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ # ghc-patch it has awfully unportable (across cabal versions) ghc detection code
+ # but in gentoo we install it to fixed patch, so remove Setup.hs detection code
+ cabal-mksetup
+
+ # and use gentoo's hardcoded one:
+ # a few things we need to replace, and example values
+ # GHC_PATHS_LIBDIR /usr/lib64/ghc-6.12.0.20091010
+ # GHC_PATHS_DOCDIR /usr/share/doc/ghc-6.12.0.20091010/html
+ # GHC_PATHS_GHC_PKG /usr/bin/ghc-pkg
+ # GHC_PATHS_GHC /usr/bin/ghc (be careful: GHC_PATHS_GHC is a substring of GHC_PATHS_GHC_PKG)
+
+ cat >"${S}/GHC/Paths.hs" <<-EOF
+ module GHC.Paths ( ghc, ghc_pkg, libdir, docdir ) where
+
+ libdir, docdir, ghc, ghc_pkg :: FilePath
+
+ libdir = "$(ghc-libdir)"
+ docdir = "/usr/share/doc/ghc-$(ghc-version)/html"
+
+ ghc = "$(ghc-getghc)"
+ ghc_pkg = "$(ghc-getghcpkg)"
+ EOF
+}
diff --git a/dev-haskell/ghc-paths/metadata.xml b/dev-haskell/ghc-paths/metadata.xml
new file mode 100644
index 000000000000..522384de8446
--- /dev/null
+++ b/dev-haskell/ghc-paths/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>