summaryrefslogtreecommitdiff
path: root/dev-haskell/email-validate/email-validate-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/email-validate/email-validate-2.0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/email-validate/email-validate-2.0.1.ebuild')
-rw-r--r--dev-haskell/email-validate/email-validate-2.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/email-validate/email-validate-2.0.1.ebuild b/dev-haskell/email-validate/email-validate-2.0.1.ebuild
new file mode 100644
index 000000000000..28312d90270c
--- /dev/null
+++ b/dev-haskell/email-validate/email-validate-2.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Validating an email address string against RFC 5322"
+HOMEPAGE="http://porg.es/blog/email-address-validation-simpler-faster-more-correct"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.0:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-2
+ >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.4.1
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"