summaryrefslogtreecommitdiff
path: root/dev-haskell/edit-distance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/edit-distance
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/edit-distance')
-rw-r--r--dev-haskell/edit-distance/Manifest4
-rw-r--r--dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild33
-rw-r--r--dev-haskell/edit-distance/edit-distance-0.2.2.1.ebuild28
-rw-r--r--dev-haskell/edit-distance/metadata.xml14
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/edit-distance/Manifest b/dev-haskell/edit-distance/Manifest
new file mode 100644
index 000000000000..013edd1ef7e4
--- /dev/null
+++ b/dev-haskell/edit-distance/Manifest
@@ -0,0 +1,4 @@
+DIST edit-distance-0.2.2.1.tar.gz 13228 BLAKE2B a7e57e19f61497cfa24c1a038e860d2b0d616f4a3528db3c315c12f3bd04554e003009f1b07b2fdd6be7a8387b0205dde4d00da8b0a05f5c4b7ab0c17fca159f SHA512 67d19c9f5712191f88641d32ff0b84aaf05c2acd71cfa81a17675690ac9076b34aff687afa8501f8b22ddcece12a439e053265d14b70dc155b0e08406050fdd7
+EBUILD edit-distance-0.2.2.1-r1.ebuild 838 BLAKE2B 92111696593b9386bea3a157dd8766ec2b2693f2e1f0de25b20bf017bcb59b19264fb871f7f0cfdde14a72d698d8ec8e4df69edead22797d8fc7b8d8b1726a68 SHA512 44dba2d4514fe0d6a385b5ee9dabe306a2737b09e1f68f631bd84402175b0a088b7d64a31c636c8f76c1015d93c11ece407fbd638b65814d0315284ce342a496
+EBUILD edit-distance-0.2.2.1.ebuild 781 BLAKE2B a876ee85df8a62d6d0732922a9547ddb0c293b80e393f91781edc877cc46dfd8b0cd1e3739ae8b5cea39c76bfa7045f86e08294e210fd3c82b04690e65b26ecb SHA512 754f9971f54b0a0e21481b73cf0446960845f05806d2c1634140ec8c3281916d847d46b670b3b1f11eed8380c422b145a5c6fe3bba0c62473a353e5a7944a329
+MISC metadata.xml 497 BLAKE2B 934f2f3ee39e2f9d8d10b11961e3e97a464843310378f7121d1e96e06d7c75f7aa68e17a97a7009d3af5f23101b79267b2e57e19d281f42c59e88a33ee189d99 SHA512 f84d69e8385d45779047219523a748ff08e61ddf83649f37c0a253688006fbcc09ba72d81b78caa059fd73dc491ec9f96f524fbeae0cf333f86bbb0561df921c
diff --git a/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild b/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild
new file mode 100644
index 000000000000..c26a93d9ee49
--- /dev/null
+++ b/dev-haskell/edit-distance/edit-distance-0.2.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Levenshtein and restricted Damerau-Levenshtein edit distances"
+HOMEPAGE="https://github.com/phadej/edit-distance"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-haskell/random-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4
+ >=dev-haskell/test-framework-0.1.1
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && <2.9' 'QuickCheck >= 2.4'
+}
diff --git a/dev-haskell/edit-distance/edit-distance-0.2.2.1.ebuild b/dev-haskell/edit-distance/edit-distance-0.2.2.1.ebuild
new file mode 100644
index 000000000000..38b054001340
--- /dev/null
+++ b/dev-haskell/edit-distance/edit-distance-0.2.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Levenshtein and restricted Damerau-Levenshtein edit distances"
+HOMEPAGE="https://github.com/phadej/edit-distance"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND=">=dev-haskell/random-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
+ >=dev-haskell/test-framework-0.1.1
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/edit-distance/metadata.xml b/dev-haskell/edit-distance/metadata.xml
new file mode 100644
index 000000000000..a2d0a723f92f
--- /dev/null
+++ b/dev-haskell/edit-distance/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Optimized edit distances for fuzzy matching, including Levenshtein and restricted Damerau-Levenshtein algorithms.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">batterseapower/edit-distance</remote-id>
+ </upstream>
+</pkgmetadata>