summaryrefslogtreecommitdiff
path: root/dev-haskell/edisonapi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/edisonapi
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/edisonapi')
-rw-r--r--dev-haskell/edisonapi/Manifest3
-rw-r--r--dev-haskell/edisonapi/edisonapi-1.3.1.ebuild30
-rw-r--r--dev-haskell/edisonapi/metadata.xml19
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/edisonapi/Manifest b/dev-haskell/edisonapi/Manifest
new file mode 100644
index 000000000000..c22789196b04
--- /dev/null
+++ b/dev-haskell/edisonapi/Manifest
@@ -0,0 +1,3 @@
+DIST EdisonAPI-1.3.1.tar.gz 30512 BLAKE2B 7ed05eccc78814672538e3be05fa3d265cd883f080b3e0b10ef57a73473e26597c7c01673d842a9c16306ef67f17a5fed78b7a5060dfe73bbd68a5cdd4d9ea41 SHA512 677161da64856421c834856ee2f5ef7f59880883433d5c5c4061f0ab2faa0cb39c4eb83061820b77dab852acc4cce5dc75740fe454b15dbc2e67e6e84510ce42
+EBUILD edisonapi-1.3.1.ebuild 679 BLAKE2B 17def60d02558bd9a89a67d3cfce9e0ee22d44c8a976d1c3f13eeeebe74a16782bd8c9dd500da6deeb7254fdb4a285bb8a2950de8960a792784915b99f948f53 SHA512 1955ce83113e7c655e3c66315179cd3d87cd25a8963d35b88c416ef3f1a639c7cd64b4b8794a427fe11c935b33c21cfbd575be55148b2f7a6b0c6f5a664f90d6
+MISC metadata.xml 825 BLAKE2B df4da54ccc2fe1f75a6a9246e3c456e399c021b1a4955fa826a41ad753c5656153f831fc2b81b8f3c1ec9864c0e60a0815ed05dbbe5d3afc8d7b4aa1584b9487 SHA512 e9f396de6cf64bf70188595f431e434dccab4a8975ce21f03c25aa2d6c672c07ac8048106581a0729e79d7b2a7da9c3921a930afbd1f87a585bd8078d9bd210a
diff --git a/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild b/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild
new file mode 100644
index 000000000000..9e3866aea2bb
--- /dev/null
+++ b/dev-haskell/edisonapi/edisonapi-1.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="EdisonAPI"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library of efficient, purely-functional data structures (API)"
+HOMEPAGE="http://rwd.rdockins.name/edison/home/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"
diff --git a/dev-haskell/edisonapi/metadata.xml b/dev-haskell/edisonapi/metadata.xml
new file mode 100644
index 000000000000..dac5f3d4c343
--- /dev/null
+++ b/dev-haskell/edisonapi/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Edison is a library of purely functional data structures written by
+ Chris Okasaki. It is named after Thomas Alva Edison and for the
+ mnemonic value EDiSon (Efficent Data Structures).
+ Edison provides several families of abstractions, each with
+ multiple implementations. The main abstractions provided by Edison are:
+ Sequences such as stacks, queues, and dequeues;
+ Collections such as sets, bags and heaps; and
+ Associative Collections such as finite maps and priority queues
+ where the priority and element are distinct.
+ </longdescription>
+</pkgmetadata>