summaryrefslogtreecommitdiff
path: root/dev-haskell/distributive/distributive-0.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/distributive/distributive-0.5.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/distributive/distributive-0.5.2.ebuild')
-rw-r--r--dev-haskell/distributive/distributive-0.5.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/distributive/distributive-0.5.2.ebuild b/dev-haskell/distributive/distributive-0.5.2.ebuild
new file mode 100644
index 000000000000..ddd8dca19a2b
--- /dev/null
+++ b/dev-haskell/distributive/distributive-0.5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: +tagged,+semigroups
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Distributive functors -- Dual to Traversable"
+HOMEPAGE="https://github.com/ekmett/distributive/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base-orphans-0.5:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/semigroups-0.11:=[profile?] <dev-haskell/semigroups-1:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-1:=[profile?]
+ >=dev-haskell/transformers-compat-0.3:=[profile?] <dev-haskell/transformers-compat-1:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ >=dev-haskell/cabal-doctest-1 <dev-haskell/cabal-doctest-1.1
+ test? ( >=dev-haskell/doctest-0.11.1 <dev-haskell/doctest-0.12
+ >=dev-haskell/generic-deriving-1.11 <dev-haskell/generic-deriving-2
+ >=dev-haskell/hspec-2 <dev-haskell/hspec-3 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=semigroups \
+ --flag=tagged
+}