summaryrefslogtreecommitdiff
path: root/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild')
-rw-r--r--dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
new file mode 100644
index 000000000000..0e9b0ff14db7
--- /dev/null
+++ b/dev-haskell/cryptohash-sha256/cryptohash-sha256-0.11.102.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+#hackport: flags: exe:executable,+use-cbits
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-256 implementation"
+HOMEPAGE="https://github.com/hvr/cryptohash-sha256"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable"
+
+CABAL_CHBINS=(
+ 'sha256sum' 'cryptohash-sha256sum'
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.10.6:=
+ executable? (
+ || (
+ ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2 )
+ =dev-haskell/base16-bytestring-1.0*
+ )
+ dev-haskell/base16-bytestring:=[profile?]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? (
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.6
+ =dev-haskell/tasty-hunit-0.10*
+ =dev-haskell/tasty-quickcheck-0.10*
+ || (
+ ( >=dev-haskell/base16-bytestring-0.1.1 <dev-haskell/base16-bytestring-0.2 )
+ =dev-haskell/base16-bytestring-1.0*
+ )
+ )
+"
+
+src_configure() {
+ local conf_flags=(
+ $(cabal_flag executable exe)
+ --flag=use-cbits
+ )
+
+ haskell-cabal_src_configure "${conf_flags[@]}"
+}