summaryrefslogtreecommitdiff
path: root/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild')
-rw-r--r--dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
new file mode 100644
index 000000000000..bb6cd4b5bc36
--- /dev/null
+++ b/dev-haskell/crypto-api/crypto-api-0.12.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A generic interface for cryptographic operations"
+HOMEPAGE="https://github.com/TomMD/crypto-api"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="all_cpolys"
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ dev-haskell/entropy:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag all_cpolys all_cpolys)
+}