summaryrefslogtreecommitdiff
path: root/dev-haskell/citeproc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/citeproc
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/citeproc')
-rw-r--r--dev-haskell/citeproc/Manifest4
-rw-r--r--dev-haskell/citeproc/citeproc-0.8.1.ebuild53
-rw-r--r--dev-haskell/citeproc/metadata.xml10
3 files changed, 60 insertions, 7 deletions
diff --git a/dev-haskell/citeproc/Manifest b/dev-haskell/citeproc/Manifest
index 2dc63e86034a..a7e6d3ea4dc2 100644
--- a/dev-haskell/citeproc/Manifest
+++ b/dev-haskell/citeproc/Manifest
@@ -1,3 +1,5 @@
DIST citeproc-0.7.tar.gz 528208 BLAKE2B 9ad395c2c3ba7bc957554b37af1a514c3deb3247a55a41b35c88b25f25db474043d18de5909e67ac5723fbfb0a5ed8161a16eb851f59c5648cfa3b30149c46fe SHA512 e24675c0d9227bd6ff5f13788c251647df1e61a65a1b0fe94d80c0bf064bd3018285ace6397d0c5f2b5d6e4ee9b91de8b90e6e4251e9914fb8fcbf58ed3c4539
+DIST citeproc-0.8.1.tar.gz 549947 BLAKE2B 055ec6466ec96cd44bf64d3cb9a9f92c5f9e825aaab93147905d3a69c5040807c1bf048196cede7d341608c96b39d9054545987b9de11be622aad6176895805e SHA512 7bce91a19e8db475b7c0c7f1f324e356dfb895fddc575b59d3fcdb8955b1ee17a82d3943edc383669a7bb5cc9fb14b3ff1cea766a2d322157017a97acddeee32
EBUILD citeproc-0.7.ebuild 1810 BLAKE2B cfe2b803599689e2a17fbbfd7d0b78aa54c65998297efc89e890da864b494d4becf0db804147bc6e8900c7571e97cd57f3140447f711d6be869eb8feb9b06351 SHA512 4239a8b0558fbb8fd48d88e7c3d0472a8d1b5a01a6610d5316f5e01c57cb88df7197ee6647cfeab1d126840d406543703cf0e4e0b2984412b0abfef3cf8656ce
-MISC metadata.xml 625 BLAKE2B 1c97c851e9df58796f5ff864598ea1d0d7b9567ffb098ef45b796c057b3a9bc6ab4219ab064d0edee79a00b49ae572b5973e34f7c0106293e48a348005436ac0 SHA512 82f117d0c7ab996e1ce3bb672d1ab7eaad4d373dea7a53b65acddca52cc028c77fda1289eea01af616a9380c6dd950cfc83d7bfaa50c9ff0e5cb5f8efae7003f
+EBUILD citeproc-0.8.1.ebuild 1742 BLAKE2B f0225a0bd77c3c1b6f53b1bbf045b1562d71bf379fd7668ef361738e11d7bc4cb559038aebd5e3fe65d9940bd2603de7d333089ed16456408caac8d9c454cd2a SHA512 e1c297c8250d2ccf85ed331e9e4acaa25e20a1bf53e3d9bc0abe91595b5e459e3d064625f4b0edd240d3d5b44573550dba3d6b323deed90c54dd29bc522da80e
+MISC metadata.xml 516 BLAKE2B 09867e0799b0faabe0990052aa2a60441e858aaebf8c6ccc943a01fabba10d70e2954a058b955c13887fb23ac2846edce8d0576a01f7e889b812cf14a378c195 SHA512 a49016fe90adf7b3a1b03e6c3b5954aab1b60293828af4d13a55886383384de7ceda86c64df7280eb16776cf1b6ba3d176de5961cd9a268df7787f476fc500dc
diff --git a/dev-haskell/citeproc/citeproc-0.8.1.ebuild b/dev-haskell/citeproc/citeproc-0.8.1.ebuild
new file mode 100644
index 000000000000..2aa2e572cfc2
--- /dev/null
+++ b/dev-haskell/citeproc/citeproc-0.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generates citations and bibliography from CSL styles"
+HOMEPAGE="https://hackage.haskell.org/package/citeproc"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="executable icu"
+
+# Many tests for this package are known to fail and this is acceptable for
+# upstream:
+# <https://github.com/jgm/citeproc#known-bugs-and-limitations>
+# The author seems to know which tests are expected to fail, but I
+# can't find documentation for exactly which ones.
+RESTRICT="test"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/data-default-0.5.2:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/pandoc-types-1.22:=[profile?] <dev-haskell/pandoc-types-1.24:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/unicode-collation-0.1.3:=[profile?] <dev-haskell/unicode-collation-0.2:=[profile?]
+ dev-haskell/uniplate:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/xml-conduit:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ executable? ( dev-haskell/aeson-pretty:=[profile?] )
+ icu? ( >=dev-haskell/text-icu-0.7.1.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/diff-0.4
+ dev-haskell/timeit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag icu icu)
+}
diff --git a/dev-haskell/citeproc/metadata.xml b/dev-haskell/citeproc/metadata.xml
index 68e37597bcd1..0066044cfb40 100644
--- a/dev-haskell/citeproc/metadata.xml
+++ b/dev-haskell/citeproc/metadata.xml
@@ -9,10 +9,8 @@
<flag name="executable">Build citeproc executable</flag>
<flag name="icu">Use Haskell bindings to the ICU library</flag>
</use>
- <longdescription>
- citeproc parses CSL style files and uses them to
- generate a list of formatted citations and bibliography
- entries. For more information about CSL, see
- &lt;https://citationstyles.org/&gt;.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">citeproc</remote-id>
+ <remote-id type="github">jgm/citeproc</remote-id>
+ </upstream>
</pkgmetadata>