summaryrefslogtreecommitdiff
path: root/dev-haskell/cassava
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/cassava
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/cassava')
-rw-r--r--dev-haskell/cassava/Manifest5
-rw-r--r--dev-haskell/cassava/cassava-0.4.4.0.ebuild35
-rw-r--r--dev-haskell/cassava/cassava-0.4.5.0.ebuild35
-rw-r--r--dev-haskell/cassava/metadata.xml15
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-haskell/cassava/Manifest b/dev-haskell/cassava/Manifest
new file mode 100644
index 000000000000..fec7e1f4d433
--- /dev/null
+++ b/dev-haskell/cassava/Manifest
@@ -0,0 +1,5 @@
+DIST cassava-0.4.4.0.tar.gz 32631 BLAKE2B dd7bf6e4b4378ffd0dad3c402465b20f8a830d1dd156826fbb0eedced28598297d0f5056d25acc1e2c8457934f077a4ac34b2caa1852397d9d0fe17b875ac3b9 SHA512 af0954754bbcfe8068ccd029417327770c60a62ecc5503b3cce5a58962940a804e167688760aec7ead42ec99b404295715d2f8fd65e4b4ed2918e1c5e063b36b
+DIST cassava-0.4.5.0.tar.gz 33104 BLAKE2B 0b0726f3060f0857ecb4135bbf71cba7e6a8b108268f948b29d6a0f61d09336097689f24bcbe77e913b5461e3872b07f6ba2d0a9e35738dc125add0a05d2650d SHA512 24f017ac44f48cdf000cab4108023d6f30a67638964831f0d7cd167bcd96ba85337d3aec6855128d370b9b383394042b3adf8dfd7299e616a385fd09125005a5
+EBUILD cassava-0.4.4.0.ebuild 1007 BLAKE2B 78a502b69a01dbeb02c3848b99308cc85e1f49fd0e880fd3f3dbdab73421e29abd657b059973857937b2a61e1ffa414429f0cfd947f73f7579cd25381ef444cb SHA512 cf13e36af2db0abab31b2abdc4e2484579f6fc17f728f3282846589adb40f4529deafd90684d3f5345e3a1b157db839ed13644166385dfd21900cded1342c30a
+EBUILD cassava-0.4.5.0.ebuild 1008 BLAKE2B fcd4ba4e7811a58e8bd7ddfa27e458d0cc53e85ad83fcf2e7acc62be2a6cd723b4932bc6961616efc2eaa4b8e97964fb0fb3dc7cdc91f7bc95e8a5f6fc2d6bb5 SHA512 8292d3557bef6360431bd2edf3602166ba18d940e8e94176bcc8f44357c4acf4bea7e7d11a9ecc717ff4f39a0273a02ff928d8739469d0d1809982282f7e7a72
+MISC metadata.xml 453 BLAKE2B 2f110faaa86a46be8651cad7690c2d5e78d4da4444ea265b4bde6ae0f5fc2743b186ffe4156475db8dd18c77865d3dab5026b8424005af7e55b401dc7c451af2 SHA512 16a89e4c5a73d93b130ca0d05328a7fbfa0759a39f80e1c80ad2d103bb26e0e0b70950b28d858aa2e366ece90991300ef0c61f43dcbcc7ec05497a77ab665438
diff --git a/dev-haskell/cassava/cassava-0.4.4.0.ebuild b/dev-haskell/cassava/cassava-0.4.4.0.ebuild
new file mode 100644
index 000000000000..d848f1373122
--- /dev/null
+++ b/dev-haskell/cassava/cassava-0.4.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A CSV parsing and encoding library"
+HOMEPAGE="https://github.com/tibbe/cassava"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.2:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ <dev-haskell/blaze-builder-0.5:=[profile?]
+ <dev-haskell/hashable-1.3:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/cassava/cassava-0.4.5.0.ebuild b/dev-haskell/cassava/cassava-0.4.5.0.ebuild
new file mode 100644
index 000000000000..09b24247000a
--- /dev/null
+++ b/dev-haskell/cassava/cassava-0.4.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A CSV parsing and encoding library"
+HOMEPAGE="https://github.com/hvr/cassava"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.2:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ <dev-haskell/blaze-builder-0.5:=[profile?]
+ <dev-haskell/hashable-1.3:=[profile?]
+ <dev-haskell/text-1.3:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ <dev-haskell/vector-0.12:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.0
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2 )
+"
diff --git a/dev-haskell/cassava/metadata.xml b/dev-haskell/cassava/metadata.xml
new file mode 100644
index 000000000000..f74f33a503ee
--- /dev/null
+++ b/dev-haskell/cassava/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ A CSV parsing and encoding library optimized for ease of use and high
+ performance.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tibbe/cassava</remote-id>
+ </upstream>
+</pkgmetadata>