summaryrefslogtreecommitdiff
path: root/dev-haskell/cabal/cabal-3.0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-haskell/cabal/cabal-3.0.1.0.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-haskell/cabal/cabal-3.0.1.0.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-3.0.1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-3.0.1.0.ebuild b/dev-haskell/cabal/cabal-3.0.1.0.ebuild
new file mode 100644
index 000000000000..88d667c8f674
--- /dev/null
+++ b/dev-haskell/cabal/cabal-3.0.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_FEATURES="lib profile" # Drop test-suite: circular depend
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.8
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RESTRICT=test # circular deps: cabal -> quickcheck -> cabal
+
+RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/parsec-3.1.13.0:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/semigroups-0.18.3:=[profile?] <dev-haskell/semigroups-0.20:=[profile?]
+ >=dev-haskell/text-1.2.3.0:=[profile?] <dev-haskell/text-1.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}"/${PN}-2.0.0.2-no-bootstrap.patch)
+
+CABAL_CORE_LIB_GHC_PV="PM:8.8.2 PM:8.8.3 PM:8.8.4"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}