summaryrefslogtreecommitdiff
path: root/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-23 08:35:49 +0100
commit386855c4d1ef509c1fd32abd721589c81669613b (patch)
tree35dc984118f0a7dc2df88313d83bb5779fd12514 /dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
parent0118ac4510d7b85ca62da20e4abd1286dd8bd752 (diff)
gentoo auto-resync : 23:10:2023 - 08:35:49
Diffstat (limited to 'dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild')
-rw-r--r--dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
new file mode 100644
index 000000000000..b6272269df21
--- /dev/null
+++ b/dev-haskell/bsb-http-chunked/bsb-http-chunked-0.0.0.4-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.1.0.9999
+
+CABAL_HACKAGE_REVISION=3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Chunked HTTP transfer encoding for bytestring builders"
+HOMEPAGE="https://github.com/sjakobi/bsb-https-chunked"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.0.0.4-disable-doctests-ghc-9_2.patch"
+)
+
+RDEPEND="
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? (
+ dev-haskell/attoparsec
+ >=dev-haskell/blaze-builder-0.2.1.4
+ >=dev-haskell/doctest-0.8
+ dev-haskell/hedgehog
+ dev-haskell/tasty
+ dev-haskell/tasty-hedgehog
+ dev-haskell/tasty-hunit
+ )
+"