summaryrefslogtreecommitdiff
path: root/dev-haskell/bitwise
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/bitwise
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/bitwise')
-rw-r--r--dev-haskell/bitwise/Manifest3
-rw-r--r--dev-haskell/bitwise/bitwise-0.1.1.1.ebuild32
-rw-r--r--dev-haskell/bitwise/metadata.xml52
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-haskell/bitwise/Manifest b/dev-haskell/bitwise/Manifest
new file mode 100644
index 000000000000..5c5a20134002
--- /dev/null
+++ b/dev-haskell/bitwise/Manifest
@@ -0,0 +1,3 @@
+DIST bitwise-0.1.1.1.tar.gz 17107 BLAKE2B 0e4ef87c50a0505aa04f248eb3356b8c3311a8a85c67d13a50621cef0e77416bd1111fcf8823c0b8d35eccd48db5241571da2f0dac8b912e4a6fd2a8ca87217d SHA512 f599411c6ce68a0ac71045ade891ae9c70a2b94b79285cdbac9e694bf227df5f0e65f115321ac62ac2878232aa91b5a6a376ae43654671fda0de2f9b0b65c70e
+EBUILD bitwise-0.1.1.1.ebuild 703 BLAKE2B e8513f4b1fd511d625c882a9fae9e86a71a5626a66ead7c65dc657ee5689b9d43e896bbabfdf95f997e531fa6de6a439330f39c81e1ee6255103ba6af0b195ed SHA512 0333d532ce88bc6226409d1fd609aee5e9331fedd3f6d9ecd289d5162b892f57f91c76d88d44d31f83e6073bfd97e11aad295d20d02161e050774b123eeea7dd
+MISC metadata.xml 1712 BLAKE2B f33c499851f77b486e0c415c9fed8912871d9b0a06a9a9fbddd6ac232bc5bb345294a8fe116939f0d6226ab9ff7bad961d4965d6584079f1faef6160332b338b SHA512 3c845b956c5480cb7a2f57dfaf41f269564731c22f68e7e5d1cd2285210f39a2f4bb0a23b6a3efec6b7d26a0a3025f21bc5c97d0b4db924eba2c11227db92fc4
diff --git a/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
new file mode 100644
index 000000000000..d67a8280c09b
--- /dev/null
+++ b/dev-haskell/bitwise/bitwise-0.1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="fast multi-dimensional unboxed bit packed Bool arrays"
+HOMEPAGE="http://code.mathr.co.uk/bitwise"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.9.2
+ test? ( >=dev-haskell/quickcheck-2.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.9' 'QuickCheck >= 2.4'
+}
diff --git a/dev-haskell/bitwise/metadata.xml b/dev-haskell/bitwise/metadata.xml
new file mode 100644
index 000000000000..4f0bc14cf689
--- /dev/null
+++ b/dev-haskell/bitwise/metadata.xml
@@ -0,0 +1,52 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Unboxed multidimensional bit packed Bool arrays with fast aggregate
+ operations based on lifting Bool operations to bitwise operations.
+
+ There are many other bit packed structures out there, but none met
+ all of these requirements:
+
+ (1) unboxed bit packed Bool array,
+
+ (2) multi-dimensional indexing,
+
+ (3) fast (de)serialization, or interoperable with foreign code,
+
+ (4) fast aggregate operations (fold, map, zip).
+
+ Quick tour of the bitwise library:
+
+ [Data.Bits.Bitwise] Lift boolean operations on &#39;Bool&#39; to bitwise
+ operations on &#39;Data.Bits.Bits&#39;.
+
+ [Data.Array.BitArray] Immutable bit arrays.
+
+ [Data.Array.BitArray.ST] Mutable bit arrays in &#39;Control.Monad.ST.ST&#39;.
+
+ [Data.Array.BitArray.IO] Mutable bit arrays in &#39;IO&#39;.
+
+ [Data.Array.BitArray.ByteString] (De)serialization.
+
+ [Codec.Image.PBM] Portable bitmap monochrome 2D image format.
+
+ Very rough performance benchmarks:
+
+ * immutable random access single bit reads:
+ @BitArray ix@ is about 40% slower than @UArray ix Bool@,
+
+ * &#39;Control.Monad.ST.ST&#39; mutable random access single bit reads:
+ @STBitArray s ix@ is about the same as @STUArray s ix Bool@,
+
+ * immutable map @Bool -&gt; Bool@:
+ @BitArray ix@ is about 85x faster than @UArray ix Bool@,
+
+ * immutable zipWith @Bool -&gt; Bool -&gt; Bool@:
+ @BitArray ix@ is about 1300x faster than @UArray ix Bool@.
+ </longdescription>
+</pkgmetadata>