summaryrefslogtreecommitdiff
path: root/dev-haskell/bio/bio-0.5.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-haskell/bio/bio-0.5.3-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/bio/bio-0.5.3-r2.ebuild')
-rw-r--r--dev-haskell/bio/bio-0.5.3-r2.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-haskell/bio/bio-0.5.3-r2.ebuild b/dev-haskell/bio/bio-0.5.3-r2.ebuild
deleted file mode 100644
index c2d94eaad256..000000000000
--- a/dev-haskell/bio/bio-0.5.3-r2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# ebuild generated by hackport 0.3.2.9999
-
-CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit eutils haskell-cabal
-
-DESCRIPTION="A bioinformatics library"
-HOMEPAGE="http://biohaskell.org/Libraries/Bio"
-SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+examples test"
-
-RDEPEND=">=dev-haskell/binary-0.4:=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/old-time:=[profile?]
- dev-haskell/parallel:=[profile?]
- dev-haskell/parsec:=[profile?]
- >=dev-haskell/quickcheck-2:2=[profile?]
- dev-haskell/random:=[profile?]
- >=dev-haskell/tagsoup-0.8:=[profile?]
- >=dev-lang/ghc-6.10.4:="
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.6"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-ghc-7.10.patch
-
- cabal_chdeps \
- 'binary >=0.4 && <0.5' 'binary >=0.4'
-}
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag examples examples) \
- $(cabal_flag test test)
-}
-
-src_test() {
- dist/build/qc/qc || die
-}
-
-src_install() {
- haskell-cabal_src_install
-
- use test && rm "${ED}"/usr/bin/qc
- # many examples collide with dev-haskell/flower
- if use examples ; then
- pushd "${ED}"/usr/bin
- local example
- for example in *
- do
- mv "${example}" "${PN}-example-${example}"
- done
- popd
- fi
-}