summaryrefslogtreecommitdiff
path: root/dev-haskell/asn1-parse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/asn1-parse
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/asn1-parse')
-rw-r--r--dev-haskell/asn1-parse/Manifest7
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild28
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild27
-rw-r--r--dev-haskell/asn1-parse/asn1-parse-0.9.4.ebuild26
-rw-r--r--dev-haskell/asn1-parse/metadata.xml14
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-haskell/asn1-parse/Manifest b/dev-haskell/asn1-parse/Manifest
new file mode 100644
index 000000000000..8b80ea0b1b1b
--- /dev/null
+++ b/dev-haskell/asn1-parse/Manifest
@@ -0,0 +1,7 @@
+DIST asn1-parse-0.8.1.tar.gz 2724 BLAKE2B 5caca79503128c9971ba1a66fe52de5fc5dcf854495562262e540c74c48aa21168399f09811d518e506bbb6fd89222dafbf074d310a4b5cd63be3a60ac0e71ef SHA512 d175903a4e2eacaf56b3c641c3a78adebfdbe263678a59c0ba44d5c1185408800f1aabad3d0ce622fe1029e204699477b36565df5bd1049ebba0df10f72eb128
+DIST asn1-parse-0.9.1.tar.gz 2785 BLAKE2B 829fe0a8cf9e1bd5b69207ac8c197e73511236d8c6260196c1ccff8ec78965ce8a6434abdf227607e0b56cd57a0af6501bcca3653518258aa93fceee5868ca92 SHA512 69799adf27188a8b1468cfc35c5a17ffe668aa30f585e8d8ff0b9153936a8825e9d548fca38d8e4ea5823ae511f179c5b56c5fe804260048bd3c5e373a077d17
+DIST asn1-parse-0.9.4.tar.gz 2860 BLAKE2B 9e9d1ae63a125215143ec31f10149fb3cd4e821c83b91e99031de8fabe73cd0c91ebba6c2ca77ec78a2093e5d1760483f4174e409d957f5f86045b91444b85c4 SHA512 10579753addf0580d33f2d7d8571bedb3b4ff3d485891dd7db8b75ae09550cbd42ee9d00a452263810079eeb77ec630687b193a6d4b538bfdb683b92c9e64637
+EBUILD asn1-parse-0.8.1.ebuild 749 BLAKE2B 2dde71cdaa4d3ed474ff7b3adeea5c20b91bf1f0a6a44e2c6113fd0253f6ffbe0dad5690091ed7d2171166a1d6002add4c433c9aea17d3093b8be93ff1ccd508 SHA512 6326ca72394a8be7ca0ee76a9b2e02909fad85cd8bc1ae65f4158779f75a6aff5e850143343db2c46397d2ae2a028d879bc0cdff8d9e23a7b79c6877c9c42014
+EBUILD asn1-parse-0.9.1.ebuild 705 BLAKE2B 5b7b269b105174f4339587d8a095ef54c84fc8e52de7aac07df205b6db8ad1a0d2d0796399d6f8096f12e5fe1f56e1957a1c81e30348e0907a35911de6007900 SHA512 53e8914e4d8a6e125bf6dfd8df0e3a9474fa29bfba5c837c7197496f1163e8300813194da5c6e8841e663933f711f1175648049a13d9a021fd65e5df0d72a917
+EBUILD asn1-parse-0.9.4.ebuild 678 BLAKE2B 2b3db5b0f77cd5850a9adce614548895fb6499dbf2e7528cedde2539cfe3b9378132df7ed1099a17aa8222ebb7faace7362d1045fa3322f19bb008eda3b93645 SHA512 8e68f05376c669b40e7d1ce94496a5f9deecba5adb7ae576680d70d3273ce9c703c36e5a876da0e8113d952498cd3f948a8d96d6e7dc6792eee252c8c6922bdf
+MISC metadata.xml 463 BLAKE2B 7c3abc8b99ff29bd4ccd577649a7f1a543eac9c85e29381e510ab824e7b03b116578377a172317fc7bec58bfcdb9a3a6e91a31e0226ef526baa107f44b0479d7 SHA512 8f66fdcc7b44e78d49916787df1efe998cf79136ba3bb1ed0221b85ffc9e23b8b340fafe6da611c8e95cfd9e041699d48f101bd07c5e9283c4d1829f6f859411
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild
new file mode 100644
index 000000000000..bd752049a8a0
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.8.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.8:=[profile?]
+ >=dev-haskell/asn1-types-0.2:=[profile?] <dev-haskell/asn1-types-0.3:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8.0.2
+"
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild
new file mode 100644
index 000000000000..788531165dac
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/asn1-parse/asn1-parse-0.9.4.ebuild b/dev-haskell/asn1-parse/asn1-parse-0.9.4.ebuild
new file mode 100644
index 000000000000..aec52edcf62f
--- /dev/null
+++ b/dev-haskell/asn1-parse/asn1-parse-0.9.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Simple monadic parser for ASN1 stream types"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/asn1-encoding-0.9:=[profile?]
+ >=dev-haskell/asn1-types-0.3:=[profile?] <dev-haskell/asn1-types-0.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/asn1-parse/metadata.xml b/dev-haskell/asn1-parse/metadata.xml
new file mode 100644
index 000000000000..26861d6a2692
--- /dev/null
+++ b/dev-haskell/asn1-parse/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ Simple monadic parser for ASN1 stream types, when ASN1 pattern matching is not convenient.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-asn1</remote-id>
+ </upstream>
+</pkgmetadata>