summaryrefslogtreecommitdiff
path: root/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild')
-rw-r--r--dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild b/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
new file mode 100644
index 000000000000..2b76e631b499
--- /dev/null
+++ b/dev-haskell/ascii-progress/ascii-progress-0.2.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A simple progress bar for the console"
+HOMEPAGE="https://github.com/yamadapc/haskell-ascii-progress"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-haskell/ansi-terminal:=[profile?]
+ >=dev-haskell/async-2.0.1.5:=[profile?]
+ >=dev-haskell/conduit-1.2:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?]
+ dev-haskell/http:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-2.1 <dev-haskell/hspec-3
+ >=dev-haskell/quickcheck-2.6 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}