summaryrefslogtreecommitdiff
path: root/dev-haskell/ansi-wl-pprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-haskell/ansi-wl-pprint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-haskell/ansi-wl-pprint')
-rw-r--r--dev-haskell/ansi-wl-pprint/Manifest5
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.1.ebuild30
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild30
-rw-r--r--dev-haskell/ansi-wl-pprint/metadata.xml17
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/Manifest b/dev-haskell/ansi-wl-pprint/Manifest
new file mode 100644
index 000000000000..9e7d3053beba
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/Manifest
@@ -0,0 +1,5 @@
+DIST ansi-wl-pprint-0.6.7.1.tar.gz 14862 BLAKE2B 4b51ea893ce5aa80e40d53b928ef3cc076a3271da50d715faf52e6f067be270b5362a2e3ef6d1890cf9aa2c4397c1b9c7e75aaf05214fab42a930098470750ac SHA512 e0524f7ba0e6ba3eefc2c04d0186579c70687c65d672e11b09a6b4352ae51f2b30e9c4a4753ca30840d24c82be8f6faa1183c29a2ee154b8c2485e1c01cad546
+DIST ansi-wl-pprint-0.6.7.3.tar.gz 14983 BLAKE2B d9de853cb03cdb23f061820aee0ac48abc513db4e0feb00529869f2ace742843b312d74fa737897b5690720a3537154f1b876e309360cdc41ffe1f84b93521ba SHA512 c5b41ee5890251ff3524bca9d5d0b457b54838906f4145e09e68cf88cb11e7bd59e05ba99c660ad61a9fcfb4e9201be4c916de2a066dfca12922292790590eba
+EBUILD ansi-wl-pprint-0.6.7.1.ebuild 805 BLAKE2B 2f1dd57136f2d6fccf4033b9e1078b2bc61d3bbd090cdcf3c8cd6e837c7812a885aeebc1379e871f84d8aebe472b81dec08d3804f11556466fb4db868a107559 SHA512 0051f0146d07ca734cb54ebe2612a59cbe7abb771699ca98b65a781cfc4aa74ac89878f6295f1019ea70d59e97e91f33947dc7666ac41a81b40431d465ffb28f
+EBUILD ansi-wl-pprint-0.6.7.3.ebuild 802 BLAKE2B c2434932b4d41b653ad97e29a1a08400bd6e6eb5cbc11dd89fe40f71c3990f5a903ab1d2901172fb304854c3051fbbfe90f3a6f9b62361d106e26b14976b8ccb SHA512 a62c15242ea5898d492d86675a92f29766c499ea0ea0c77c61065998517eac80875d74e1dfe66007a5bac6363423d4d567f916c6ce4f54d351b06de39847c4ff
+MISC metadata.xml 640 BLAKE2B bbc4f8f5621d458eab0c1ea200b6a70201cc3825033302b57d235c76e3aba1f80dd07b8e204a1546a43b92782d93ca6c0c776d8fba1f6e35cf36901b19038da3 SHA512 7999a66b49fce8bdd94736eeb4eb47858b06daae8928053531df4892f34e46f5135c92c9b7659446573b144e6e8d37d27306b608759eb30d2e71addb81a7ffd1
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.1.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.1.ebuild
new file mode 100644
index 000000000000..e42b98257c9d
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/batterseapower/ansi-wl-pprint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="example"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag example example)
+}
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
new file mode 100644
index 000000000000..378462f16834
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="example"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag example example)
+}
diff --git a/dev-haskell/ansi-wl-pprint/metadata.xml b/dev-haskell/ansi-wl-pprint/metadata.xml
new file mode 100644
index 000000000000..2ffd00b91707
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This is a pretty printing library based on Wadler's paper "A Prettier Printer". It has been enhanced with support for ANSI terminal colored output using the ansi-terminal package.
+ </longdescription>
+ <use>
+ <flag name="example">Build the example application.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">batterseapower/ansi-wl-pprint</remote-id>
+ </upstream>
+</pkgmetadata>