summaryrefslogtreecommitdiff
path: root/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild')
-rw-r--r--dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
new file mode 100644
index 000000000000..378462f16834
--- /dev/null
+++ b/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-0.6.7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
+HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="example"
+
+RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?] <dev-haskell/ansi-terminal-0.7:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag example example)
+}