summaryrefslogtreecommitdiff
path: root/dev-go/gogo-protobuf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-go/gogo-protobuf
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-go/gogo-protobuf')
-rw-r--r--dev-go/gogo-protobuf/Manifest3
-rw-r--r--dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild41
-rw-r--r--dev-go/gogo-protobuf/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-go/gogo-protobuf/Manifest b/dev-go/gogo-protobuf/Manifest
new file mode 100644
index 000000000000..6ed0ad5db65c
--- /dev/null
+++ b/dev-go/gogo-protobuf/Manifest
@@ -0,0 +1,3 @@
+DIST gogo-protobuf-0.4_p20170815.tar.gz 2572704 SHA256 f035a5be2c07ddbbfae821b372af68f70db504d1165c55b717dc4d5afcdf055f SHA512 3ab7f2e0006e537999e5fd0ba52272ad53c4707688401bb1e415007600f1ac5200dd8a03bd706977813b17c7712ba94a8b43fcf13b6498114a1d79c72bb216e7 WHIRLPOOL 7c7095989658bacd20c7038187344ea19c9111c8b2ba4601f0d06bd6ebc3309bbe0575073a0debb3d942a14c8ffc2986be5287a2413e8b1240560415b0b06a53
+EBUILD gogo-protobuf-0.4_p20170815.ebuild 1048 SHA256 4e5520302e301b4793ce2c7c7e9565d221117b8287b4a2308efffc225a4dd8f4 SHA512 8c90de5ba3f264e075f366ad3ac40043cddf360da5ec16c7f44522ce9a5c3e93d0f3bafc07ffbef7fdb929172bc47db1bacc42c6345097887ed432675a2351d9 WHIRLPOOL 771ba66d518ad1fa91532376bdb7c9a01aef3be5e30b4b184d10656136c658c0daaa2f69e5c0e9d60a1f08eddebfdb94a0eb74ef709401b01b5e82d421c59ecc
+MISC metadata.xml 323 SHA256 96703eb97233fab397e13dcd1bbcc4ac469de28cea3fc3529e416510241eebae SHA512 d5bbbadf23e0bf2ef8757ab4231aff3c2a45b861d9ca0439c41863b91e24157680663385b65d8fa9ceade83e3e4705bcb54cba67d56a9e48bb2f1789c78103dc WHIRLPOOL 2e597a0124014ecfba3841a9f71885737e4dfb8b9daecdec0aac01cca4565ed81c7d2fc76c376bc66207841fbd9492373e627f4add771df7a87bc4d73cd2882c
diff --git a/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
new file mode 100644
index 000000000000..0abb1c6156a3
--- /dev/null
+++ b/dev-go/gogo-protobuf/gogo-protobuf-0.4_p20170815.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/gogo/protobuf"
+EGIT_COMMIT="fcdc5011193ff531a548e9b0301828d5a5b97fd8"
+
+inherit golang-build golang-vcs-snapshot
+
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Protocol Buffers for Go with Gadgets"
+HOMEPAGE="https://github.com/gogo/protobuf"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogo || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofast || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogoslick || die
+ GOPATH="${WORKDIR}/${P}"\
+ go install ${EGO_PN}/protoc-gen-gogofaster || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/protoc-gen-{gogo,gofast,gogofast,gogofaster}
+ dodoc src/${EGO_PN}/README
+}
diff --git a/dev-go/gogo-protobuf/metadata.xml b/dev-go/gogo-protobuf/metadata.xml
new file mode 100644
index 000000000000..180140b98774
--- /dev/null
+++ b/dev-go/gogo-protobuf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel RĂ¼ger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gogo/protobuf</remote-id>
+ </upstream>
+</pkgmetadata>