summaryrefslogtreecommitdiff
path: root/dev-go/go-tour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/go-tour
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-tour')
-rw-r--r--dev-go/go-tour/Manifest3
-rw-r--r--dev-go/go-tour/go-tour-0_p20160209.ebuild36
-rw-r--r--dev-go/go-tour/metadata.xml10
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-go/go-tour/Manifest b/dev-go/go-tour/Manifest
new file mode 100644
index 000000000000..0b1e3161d4ad
--- /dev/null
+++ b/dev-go/go-tour/Manifest
@@ -0,0 +1,3 @@
+DIST go-tour-0_p20160209.tar.gz 275272 BLAKE2B c3d98bf839fc62a43eb7b994a798ab977c19756160930f7ecda39543e8bf4f793ec1eb4f2e3fb202e2bd9b1d8738eed02b40510047fcfe5274ae3c99410dde0a SHA512 bc9131e6173f72ea01c3062454a47a90301ad01bc1ea356ef09b81ad2d887759671ee9700f2c6b47821fc02c49297b8797d732ae0e9b414205e483d30579d2e9
+EBUILD go-tour-0_p20160209.ebuild 1108 BLAKE2B 5a55e6c40ade0d49d4121dce55dde77172f9f046a45815a868b355768c59a0f3f2efd1041ea1d22d3c2fceece344d04b9b2eb5cf8fe3551dae97c938019f00a8 SHA512 ebeb76acf12afd2146deac37cdfc9db89f230727059ad3992ce8da4d843e1cdb42ddb2c693378045684d74917e3b75c4a3eeaf96079aa5df8abea68d2d863b3f
+MISC metadata.xml 302 BLAKE2B b47fb7e4329ee56fd11c666f3493a1ad78c816390b7f1748c6bccb780aaf2440fc18f6d75352f80c481b40bdd9a060c192ed2fd1d6076bedf45aa57d67c6a2f0 SHA512 c49a4e57f4cc812eb4412bd71b02ac70785afd6d1793b09212f15a72a83d92a5c5f769ac569b7fe1e9f31b49b5abae913c647c75e82c3e7c3405e20819ff3b37
diff --git a/dev-go/go-tour/go-tour-0_p20160209.ebuild b/dev-go/go-tour/go-tour-0_p20160209.ebuild
new file mode 100644
index 000000000000..5dd5bec1b027
--- /dev/null
+++ b/dev-go/go-tour/go-tour-0_p20160209.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN="golang.org/x/tour/..."
+
+EGIT_COMMIT="6b2e5b35ce8ed092eaedc3d2a2294373a639f122"
+ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+inherit golang-vcs-snapshot golang-build
+
+DESCRIPTION="A Tour of Go"
+HOMEPAGE="https://tour.golang.org"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-tools:="
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_PN%/*}" || die
+ GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ [[ -x $(find "${T}" -name a.out) ]] || die "a.out not found"
+}
+
+src_install() {
+ GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ exeinto "$(go env GOTOOLDIR)"
+ newexe bin/gotour tour
+ insinto "$(go env GOROOT)"
+ doins -r src
+}
diff --git a/dev-go/go-tour/metadata.xml b/dev-go/go-tour/metadata.xml
new file mode 100644
index 000000000000..46777271d39c
--- /dev/null
+++ b/dev-go/go-tour/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/tour</remote-id>
+ </upstream>
+</pkgmetadata>