summaryrefslogtreecommitdiff
path: root/dev-go/go-tour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-go/go-tour
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-go/go-tour')
-rw-r--r--dev-go/go-tour/Manifest4
-rw-r--r--dev-go/go-tour/go-tour-0_p20160209.ebuild36
-rw-r--r--dev-go/go-tour/metadata.xml10
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-go/go-tour/Manifest b/dev-go/go-tour/Manifest
new file mode 100644
index 000000000000..3ffc0a7a940f
--- /dev/null
+++ b/dev-go/go-tour/Manifest
@@ -0,0 +1,4 @@
+DIST go-tour-0_p20160209.tar.gz 275272 SHA256 f50ce5a75f1dd9d625830c0907a5b611455b052ed1e287f5d2f9428759e14223 SHA512 bc9131e6173f72ea01c3062454a47a90301ad01bc1ea356ef09b81ad2d887759671ee9700f2c6b47821fc02c49297b8797d732ae0e9b414205e483d30579d2e9 WHIRLPOOL a2e117e2f50c83013604e85fb03919a25eacc1494dce9c53929d6bcbb22367d88f7b073d292261909767c91fda8f5a10380f452938ac3bba78c5939634206e9c
+EBUILD go-tour-0_p20160209.ebuild 1108 SHA256 fe142d9c7f43ac28020824d1ef3d969d56d26446a78079989ba3a78af157e5ec SHA512 ebeb76acf12afd2146deac37cdfc9db89f230727059ad3992ce8da4d843e1cdb42ddb2c693378045684d74917e3b75c4a3eeaf96079aa5df8abea68d2d863b3f WHIRLPOOL 3254d542a32b74f7722949aedca4dd227be8fae61985a5f6c9a9715c2807b4d8b8f26200a0e0576dfd8a963de56065334c2d16e62335cca360c2ada3b6f897a6
+MISC ChangeLog 443 SHA256 8bb824c93634c9f69d19d0f0818e01e368501ee11f2eea949105b8e7db2b2f3a SHA512 97812caffad786ad05a485ea12cd1f2d1ba54cc897fba4c9ef615ea3a21eaf14809256d8afe18504588dcc0b7f8b933c632f68710acdd271dde74fd638511e72 WHIRLPOOL 6b28ae31649e276afb29ba5a6030b2aad4fc5a181c035eebcf3322b72c518f6fe597dda43abd5c64fad297ff03d5d2525deabc1343e9805238db783baccbfa24
+MISC metadata.xml 302 SHA256 29a90b9f626835ae48f5b8fd133d53564780379e74178be163644bc5e51a4d0f SHA512 c49a4e57f4cc812eb4412bd71b02ac70785afd6d1793b09212f15a72a83d92a5c5f769ac569b7fe1e9f31b49b5abae913c647c75e82c3e7c3405e20819ff3b37 WHIRLPOOL 99cdf6dda20e09de680685d00a4b170c3778bc1917318bd0e406be27cba953a41b966cf77de028d77e54ec685ef0f6998905dad79bb4ab8cbfb4de05e2e600ef
diff --git a/dev-go/go-tour/go-tour-0_p20160209.ebuild b/dev-go/go-tour/go-tour-0_p20160209.ebuild
new file mode 100644
index 000000000000..5dd5bec1b027
--- /dev/null
+++ b/dev-go/go-tour/go-tour-0_p20160209.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN="golang.org/x/tour/..."
+
+EGIT_COMMIT="6b2e5b35ce8ed092eaedc3d2a2294373a639f122"
+ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+inherit golang-vcs-snapshot golang-build
+
+DESCRIPTION="A Tour of Go"
+HOMEPAGE="https://tour.golang.org"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND="dev-go/go-tools:="
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_PN%/*}" || die
+ GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ [[ -x $(find "${T}" -name a.out) ]] || die "a.out not found"
+}
+
+src_install() {
+ GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ exeinto "$(go env GOTOOLDIR)"
+ newexe bin/gotour tour
+ insinto "$(go env GOROOT)"
+ doins -r src
+}
diff --git a/dev-go/go-tour/metadata.xml b/dev-go/go-tour/metadata.xml
new file mode 100644
index 000000000000..46777271d39c
--- /dev/null
+++ b/dev-go/go-tour/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/tour</remote-id>
+ </upstream>
+</pkgmetadata>