summaryrefslogtreecommitdiff
path: root/dev-go/go-tour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-go/go-tour
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-go/go-tour')
-rw-r--r--dev-go/go-tour/Manifest4
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild (renamed from dev-go/go-tour/go-tour-0_p20160209.ebuild)30
2 files changed, 20 insertions, 14 deletions
diff --git a/dev-go/go-tour/Manifest b/dev-go/go-tour/Manifest
index 0b1e3161d4ad..3bc1564e6ed8 100644
--- a/dev-go/go-tour/Manifest
+++ b/dev-go/go-tour/Manifest
@@ -1,3 +1,3 @@
-DIST go-tour-0_p20160209.tar.gz 275272 BLAKE2B c3d98bf839fc62a43eb7b994a798ab977c19756160930f7ecda39543e8bf4f793ec1eb4f2e3fb202e2bd9b1d8738eed02b40510047fcfe5274ae3c99410dde0a SHA512 bc9131e6173f72ea01c3062454a47a90301ad01bc1ea356ef09b81ad2d887759671ee9700f2c6b47821fc02c49297b8797d732ae0e9b414205e483d30579d2e9
-EBUILD go-tour-0_p20160209.ebuild 1108 BLAKE2B 5a55e6c40ade0d49d4121dce55dde77172f9f046a45815a868b355768c59a0f3f2efd1041ea1d22d3c2fceece344d04b9b2eb5cf8fe3551dae97c938019f00a8 SHA512 ebeb76acf12afd2146deac37cdfc9db89f230727059ad3992ce8da4d843e1cdb42ddb2c693378045684d74917e3b75c4a3eeaf96079aa5df8abea68d2d863b3f
+DIST go-tour-0_p20180810.tar.gz 319048 BLAKE2B 43c4ca53d939cf7590c8e3607e2089974f1b40dc9268ccbf9100e36d258d76a828c5512e662f20d125c07d0a35d48d3004c8f06d6f80a6a1645099d4ca592c57 SHA512 73eb1b7a228d046d572b2c781cdd7b43ef57de982987ab5808cbb2775c34c9805fac3c52fd68edd34ccadec5169ce5d61234eee553daf0b9ef2d2529e2817b44
+EBUILD go-tour-0_p20180810.ebuild 1094 BLAKE2B 2cbb46860460043328b8db825da7855d99105b109749cb94e6c79d6282d7a74b761db19ba3bca622da654a23d54bdf24b9e770d5b212c90c978bda2cc32b319d SHA512 43818de5961041d32b8227c561cbe7c7e5b93b13006580979e1c90d3d2d60d82cbeb280b41a6e481c0fc60183b66e0e18bb2866a70d81f542f4514f93f96f905
MISC metadata.xml 302 BLAKE2B b47fb7e4329ee56fd11c666f3493a1ad78c816390b7f1748c6bccb780aaf2440fc18f6d75352f80c481b40bdd9a060c192ed2fd1d6076bedf45aa57d67c6a2f0 SHA512 c49a4e57f4cc812eb4412bd71b02ac70785afd6d1793b09212f15a72a83d92a5c5f769ac569b7fe1e9f31b49b5abae913c647c75e82c3e7c3405e20819ff3b37
diff --git a/dev-go/go-tour/go-tour-0_p20160209.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
index 5dd5bec1b027..0266d4dd62b2 100644
--- a/dev-go/go-tour/go-tour-0_p20160209.ebuild
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
EGO_PN="golang.org/x/tour/..."
-EGIT_COMMIT="6b2e5b35ce8ed092eaedc3d2a2294373a639f122"
+EGIT_COMMIT="d642b9371986f5bb2152547a0d525a57f634c3ef"
ARCHIVE_URI="https://github.com/golang/tour/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
inherit golang-vcs-snapshot golang-build
@@ -15,22 +15,28 @@ SRC_URI="${ARCHIVE_URI}"
LICENSE="BSD"
SLOT="0"
IUSE=""
-DEPEND="dev-go/go-tools:="
+DEPEND="dev-go/go-net:=
+ dev-go/go-tools:="
src_compile() {
- # Create a writable GOROOT in order to avoid sandbox violations.
- cp -sR "$(go env GOROOT)" "${T}/goroot" || die
- rm -rf "${T}/goroot/src/${EGO_PN%/*}" || die
- GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- go build -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
- [[ -x $(find "${T}" -name a.out) ]] || die "a.out not found"
+ local x
+ mkdir -p "${T}/golibdir/src/golang.org/x" || die
+ for x in net tools; do
+ ln -s "$(get_golibdir_gopath)/src/golang.org/x/${x}" "${T}/golibdir/src/golang.org/x/${x}" || die
+ done
+ GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
+ [[ -x bin/gotour ]] || die "gotour not found"
}
src_install() {
- GOROOT="${T}/goroot" GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
- go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
exeinto "$(go env GOTOOLDIR)"
newexe bin/gotour tour
insinto "$(go env GOROOT)"
doins -r src
}
+
+src_test() {
+ GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
+ go test -v -work -x "${EGO_PN}" || die
+}