summaryrefslogtreecommitdiff
path: root/dev-go/go-md2man/go-md2man-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-go/go-md2man/go-md2man-2.0.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-go/go-md2man/go-md2man-2.0.0.ebuild')
-rw-r--r--dev-go/go-md2man/go-md2man-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-go/go-md2man/go-md2man-2.0.0.ebuild b/dev-go/go-md2man/go-md2man-2.0.0.ebuild
new file mode 100644
index 000000000000..9af47a4a7da9
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit go-module
+
+DESCRIPTION="A utility to convert markdown to man pages"
+ SRC_URI="https://github.com/cpuguy83/go-md2man/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+
+src_compile() {
+ emake BUILD_FLAGS="-mod=vendor" build
+}
+
+src_install() {
+ "${S}"/bin/go-md2man -in go-md2man.1.md -out go-md2man.1 ||
+ die "Unable to create man page"
+ dobin bin/go-md2man
+ doman go-md2man.1
+}
+
+src_test() {
+ emake test
+}