summaryrefslogtreecommitdiff
path: root/dev-go/go-md2man/go-md2man-1.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-go/go-md2man/go-md2man-1.0.8.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-go/go-md2man/go-md2man-1.0.8.ebuild')
-rw-r--r--dev-go/go-md2man/go-md2man-1.0.8.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-go/go-md2man/go-md2man-1.0.8.ebuild b/dev-go/go-md2man/go-md2man-1.0.8.ebuild
new file mode 100644
index 000000000000..c3767538421b
--- /dev/null
+++ b/dev-go/go-md2man/go-md2man-1.0.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=github.com/cpuguy83/go-md2man
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~arm64"
+ EGIT_COMMIT=v${PV}
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A utility to convert markdown to man pages"
+HOMEPAGE="https://github.com/cpuguy83/go-md2man"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+src_install() {
+ "${S}"/go-md2man -in src/${EGO_PN}/go-md2man.1.md -out go-md2man.1
+ dobin go-md2man
+ doman go-md2man.1
+}