summaryrefslogtreecommitdiff
path: root/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild')
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
new file mode 100644
index 000000000000..ec9ffb902a80
--- /dev/null
+++ b/dev-go/go-eapache-queue/go-eapache-queue-1.0.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+EGO_SRC=github.com/eapache/queue
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Fast golang queue using ring-buffer"
+HOMEPAGE="https://github.com/eapache/queue"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""