summaryrefslogtreecommitdiff
path: root/dev-go/go-crypto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/go-crypto
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-crypto')
-rw-r--r--dev-go/go-crypto/Manifest6
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20150808.ebuild47
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20160126.ebuild55
-rw-r--r--dev-go/go-crypto/go-crypto-9999.ebuild38
-rw-r--r--dev-go/go-crypto/metadata.xml10
5 files changed, 156 insertions, 0 deletions
diff --git a/dev-go/go-crypto/Manifest b/dev-go/go-crypto/Manifest
new file mode 100644
index 000000000000..804a1919ac41
--- /dev/null
+++ b/dev-go/go-crypto/Manifest
@@ -0,0 +1,6 @@
+DIST go-crypto-0_pre20150808.tar.gz 876947 BLAKE2B c6da903ec7b5308114f2e2a364d6a2936dc24be4f8f274116c811740f712f13b2926a6f84b6160c450d921dbbeeb7ce48371e593cfa4d8abf80308f3cf07ac26 SHA512 86826102ff7242259d79a31e543a03192d6b68a06635b46ebac349111bb8451605df1ad9b249c08d75895c38fb4ebbbfc716d40c8c981485395164e87db5a519
+DIST go-crypto-0_pre20160126.tar.gz 902001 BLAKE2B 54d38a9aea69e01485417cbf8a900135730dca4bc79c9d5d1187eadb11a8dfca9ef6e72056c4ed4ad4a34b172379d94e6beb82ece9031411b8aa12af85200fb2 SHA512 168129ab9581b7348fb3285e045d99a0a837ac7bd65bf9f5e7a220fffbb9e2abf76da5f521c66eea7179eba0ad8da68d6f41cd9624ea40a9da25a18838427846
+EBUILD go-crypto-0_pre20150808.ebuild 1371 BLAKE2B d19720ef683fdc1094e418a9f28bee026b67a6714f38c9f8744440be745136816cdd9883951040965a527bcb2fb29ddf81217d72f07b3652cd7010b87a92e7fd SHA512 e95dd2cd871e32c5af4aee88fb15a5a42bfa0bbfa682f425ae147dabec99a450f1bc9bc1c9fb21de2ac654de218187f5c7acec81482dfa231e7eec26f964c3d9
+EBUILD go-crypto-0_pre20160126.ebuild 1691 BLAKE2B 0d894ff62289f1a8aa3b75c017e5246e4437c0b05fc2ae71a85f4369c82ada781a8540042932b4b769233792ead9901ad22b1b50439a5902f061774682141758 SHA512 a6d995f85bb6ba42c9539a96b19d84b18de9978d2ec3706678a5c1b337e7482203563935899ed171ff10f255feef34b7158bd68f7f58b7555da7c23ba61c858d
+EBUILD go-crypto-9999.ebuild 1063 BLAKE2B 833b19a7c104703922be8f66665158d1e084537658d7e3cab5689fb8dae33a94111b524a2907f1e63547ad95f547002392ed252cd6f6b5d85f195cb4e7e57516 SHA512 54ef740fc46c68e41949e2c1fc2102b269f9cf1232f930e78f1868d859df305d75eed827c15ceddba81f2b607d054196503b0a4d8c9b71b99ab9ecabf1aa9c30
+MISC metadata.xml 304 BLAKE2B d090eb82d7631d6984390d12c602fad54f5246bc6cb940403fd5be4b4ff85d6ac99469460c89a3e1c6751aab519229ad1ed615bd9782a24a864949a59dd5c355 SHA512 1e30936f145a4bac0db6816b1ab4ee6b5c38864774023e99d9724caf50e9039798d8675d41aa939c339d99ef59ccc2485bf3b5e3077f1e60d8b850bb607807b9
diff --git a/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild b/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild
new file mode 100644
index 000000000000..32fa7915de5c
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-0_pre20150808.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=golang.org/x/crypto/...
+EGO_SRC=golang.org/x/crypto
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="83f1503f771a82af8a31f358eb825e9efb5dae6c"
+ SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go supplementary cryptography libraries"
+HOMEPAGE="https://godoc.org/golang.org/x/crypto"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
+ export GOROOT="${T}/goroot"
+ golang-build_src_compile
+}
diff --git a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
new file mode 100644
index 000000000000..159900040323
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=golang.org/x/crypto/...
+EGO_SRC=golang.org/x/crypto
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="1f22c0103821b9390939b6776727195525381532"
+ SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go supplementary cryptography libraries"
+HOMEPAGE="https://godoc.org/golang.org/x/crypto"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ rm -rf "${T}/goroot/src/${EGO_SRC}" || die
+ rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
+ export GOROOT="${T}/goroot"
+ # Exclude $(get_golibdir_gopath) from GOPATH, for bug 577908 which may
+ # or may not manifest, depending on what libraries are installed.
+ export GOPATH="${WORKDIR}/${P}"
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_test() {
+ # Exclude $(get_golibdir_gopath) from GOPATH
+ go test -v -work -x "${EGO_PN}" || die
+}
diff --git a/dev-go/go-crypto/go-crypto-9999.ebuild b/dev-go/go-crypto/go-crypto-9999.ebuild
new file mode 100644
index 000000000000..6cee16b68553
--- /dev/null
+++ b/dev-go/go-crypto/go-crypto-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+EGO_PN=golang.org/x/crypto/...
+EGO_SRC=golang.org/x/crypto
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="1e856cbfdf9bc25eefca75f83f25d55e35ae72e0"
+ SRC_URI="https://github.com/golang/crypto/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go supplementary cryptography libraries"
+HOMEPAGE="https://godoc.org/golang.org/x/crypto"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ # disable broken tests
+ sed -e 's:TestAgentForward(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
+ sed -e 's:TestRunCommandSuccess(:_\0:' \
+ -e 's:TestRunCommandStdin(:_\0:' \
+ -e 's:TestRunCommandStdinError(:_\0:' \
+ -e 's:TestRunCommandWeClosed(:_\0:' \
+ -e 's:TestFuncLargeRead(:_\0:' \
+ -e 's:TestKeyChange(:_\0:' \
+ -e 's:TestValidTerminalMode(:_\0:' \
+ -i src/${EGO_SRC}/ssh/test/session_test.go || die
+}
diff --git a/dev-go/go-crypto/metadata.xml b/dev-go/go-crypto/metadata.xml
new file mode 100644
index 000000000000..64985dedae20
--- /dev/null
+++ b/dev-go/go-crypto/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">golang/crypto</remote-id>
+ </upstream>
+</pkgmetadata>