summaryrefslogtreecommitdiff
path: root/dev-go/go-bindata/go-bindata-0_pre20151023.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-go/go-bindata/go-bindata-0_pre20151023.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-go/go-bindata/go-bindata-0_pre20151023.ebuild')
-rw-r--r--dev-go/go-bindata/go-bindata-0_pre20151023.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-go/go-bindata/go-bindata-0_pre20151023.ebuild b/dev-go/go-bindata/go-bindata-0_pre20151023.ebuild
new file mode 100644
index 000000000000..dac12764e414
--- /dev/null
+++ b/dev-go/go-bindata/go-bindata-0_pre20151023.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/jteeuwen/go-bindata/..."
+EGIT_COMMIT="a0ff2567cfb70903282db057e799fd826784d41d"
+ARCHIVE_URI="https://${EGO_PN%/*}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm"
+
+DESCRIPTION="A small utility which generates Go code from any file"
+HOMEPAGE="https://github.com/jteeuwen/go-bindata"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="CC-PD"
+SLOT="0/${PVR}"
+IUSE=""
+
+src_install() {
+ golang-build_src_install
+ dobin bin/*
+}