summaryrefslogtreecommitdiff
path: root/dev-gap/gapdoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
commitce163dcd0944d81d8406c9532b457535efca7a6d (patch)
treef7deea170544ce69e03c037101b7b5c1277966b4 /dev-gap/gapdoc
parent05ee8049e2326946a2cd1720f98384c864f0a804 (diff)
gentoo auto-resync : 22:01:2024 - 16:48:54
Diffstat (limited to 'dev-gap/gapdoc')
-rw-r--r--dev-gap/gapdoc/Manifest3
-rw-r--r--dev-gap/gapdoc/gapdoc-1.6.6.ebuild48
-rw-r--r--dev-gap/gapdoc/metadata.xml28
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-gap/gapdoc/Manifest b/dev-gap/gapdoc/Manifest
new file mode 100644
index 000000000000..e0d356cb272e
--- /dev/null
+++ b/dev-gap/gapdoc/Manifest
@@ -0,0 +1,3 @@
+DIST gapdoc-1.6.6.tar.gz 254048 BLAKE2B d9c2e7371aaa97076855bea59e2b58e9458f0bf2f37ca403ec8f35dc9d19a7ad7f2f84cfe1a607aa15cc377a7b304bced4a39f9897e8c95794cde392e2cd2e58 SHA512 48283e54b4d540c35dec11ecca4129cabb824b521ac64b25694e754c4811542a7dc3313d5c7043eadd503db10228ab9838bb250541d1193696223117ccfda2c4
+EBUILD gapdoc-1.6.6.ebuild 1077 BLAKE2B cbfe7d21aab3c51d94a4af67a0e65ab4129422f3c01bef95f298edf627ee471b1ff34bc8998df032476dc987015ec9d519061078cc7efa62ac097b78ded66e8f SHA512 0c85d81d0568b42143c5b01f1f4dc7fcffb2e1e420ad84bb69bb222997cbad04c9647478503f7913b58a0f53d5b6d59cf09849acb41f42746f29e803e5ab634f
+MISC metadata.xml 994 BLAKE2B b740c0257f637cc39e4ff12526f9c76844671a1678c26dd15b5fe80d83c19d7b2e6340de781aef9af4332adaef1df1a305b31d85a231f021ccf6ab06b024f85d SHA512 9e24cc39889bd31a427189092b90713f57bbad1b4908b2751c0882a85b1f89009879add1351fb06ec4418fb699f718f7ee331dce115a00e1553fccd21e3afefc
diff --git a/dev-gap/gapdoc/gapdoc-1.6.6.ebuild b/dev-gap/gapdoc/gapdoc-1.6.6.ebuild
new file mode 100644
index 000000000000..29ef04cc2723
--- /dev/null
+++ b/dev-gap/gapdoc/gapdoc-1.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+MY_PN=GAPDoc
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="GAP documentation structure and tooling"
+SLOT="0"
+SRC_URI="https://github.com/frankluebeck/${MY_PN}/archive/relv${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-relv${PV}"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+# PackageInfo.g defines TestFile := tst/test.tst, but that
+# file doesn't exist!
+RESTRICT=test
+
+DOCS=( CHANGES README.md )
+
+GAP_PKG_EXTRA_INSTALL=(
+ bibxmlext.dtd
+ gapdoc.dtd
+ styles
+ version
+)
+
+src_install(){
+ gap-pkg_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc -r 3k+1
+ fi
+
+ # The "example" directory is mentioned in PackageInfo.g, so we
+ # include it unconditionally, and install it in the gap package
+ # directory (so that the path in PackageInfo.g is accurate).
+ # Afterwards we symlink it into the usual USE=examples path.
+ insinto $(gap-pkg_dir)
+ doins -r example
+ dosym -r $(gap-pkg_dir)/example \
+ "/usr/share/doc/${PF}/examples/example"
+}
diff --git a/dev-gap/gapdoc/metadata.xml b/dev-gap/gapdoc/metadata.xml
new file mode 100644
index 000000000000..70eaabce12e5
--- /dev/null
+++ b/dev-gap/gapdoc/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This package contains a definition of a structure for GAP (package)
+ documentation, based on XML. It also contains conversion programs
+ for producing text-, PDF- or HTML-versions of such documents, with
+ hyperlinks if possible.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">frankluebeck/GAPDoc</remote-id>
+ </upstream>
+</pkgmetadata>