summaryrefslogtreecommitdiff
path: root/dev-gap/ctbllib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-22 16:48:54 +0000
commitce163dcd0944d81d8406c9532b457535efca7a6d (patch)
treef7deea170544ce69e03c037101b7b5c1277966b4 /dev-gap/ctbllib
parent05ee8049e2326946a2cd1720f98384c864f0a804 (diff)
gentoo auto-resync : 22:01:2024 - 16:48:54
Diffstat (limited to 'dev-gap/ctbllib')
-rw-r--r--dev-gap/ctbllib/Manifest3
-rw-r--r--dev-gap/ctbllib/ctbllib-1.3.6.ebuild63
-rw-r--r--dev-gap/ctbllib/metadata.xml19
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-gap/ctbllib/Manifest b/dev-gap/ctbllib/Manifest
new file mode 100644
index 000000000000..d11ba06ae1c6
--- /dev/null
+++ b/dev-gap/ctbllib/Manifest
@@ -0,0 +1,3 @@
+DIST ctbllib-1.3.6.tar.gz 16603964 BLAKE2B 3994c4e100bcce46b5cbe7d34d6bad310b950495607fc11fe0dabb9d72767fea38ad2a5bce633393c4df78b5dd039257fccf83fcb208eaec458e5872b363ca00 SHA512 ac4ab422bc861816363623f19cc72aa23490198192e39ddcc4b407790504a8e316c21b580217e6b4ec5f956ccf784a2b118848d11e0d9fd2efb528424349ba26
+EBUILD ctbllib-1.3.6.ebuild 1501 BLAKE2B 830d1e880ed4c298d6fac7bb7f5c9eb72b4ade3e15301e92b1e2fd40b7b12d23248e3bcd4a3348570b85454755edabf7406f774a9dc07bdeba6c5b2416030385 SHA512 83b6cd86004e4f45fbeba82622aa6cdad82123edbb235591cd06b299ead3eff3ddfe7c51148d90594fce9d96bc30327b06625c7a38baf6e99662f0e7d030ef3b
+MISC metadata.xml 613 BLAKE2B 197d041ff3c484fe531956e92f9e5ac575e3170f59ea4ffdb1cca52806a8e64865a5aaf6b54aa11d721bd3518e3533e9efa3506e3e6bc4d4fd01e5aad3998b4a SHA512 d38f694a2177f630a6135172f3f4c34545c7cb703623d4f442debe55be8d5ce8de50d0f922a51cacf750074c09e5c6facb58618e854e6945fe0ede873ea21a21
diff --git a/dev-gap/ctbllib/ctbllib-1.3.6.ebuild b/dev-gap/ctbllib/ctbllib-1.3.6.ebuild
new file mode 100644
index 000000000000..07eedf502da9
--- /dev/null
+++ b/dev-gap/ctbllib/ctbllib-1.3.6.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gap-pkg
+
+DESCRIPTION="The GAP Character Table Library"
+SLOT="0"
+SRC_URI="https://www.math.rwth-aachen.de/~Thomas.Breuer/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-gap/atlasrep"
+BDEPEND="test? (
+ dev-gap/browse
+ dev-gap/spinsym
+ dev-gap/tomlib
+)"
+
+# These are "extra" docs and not the HTML produced by GAPDoc. The glob
+# gets expanded if we use a plain variable but not if we use a bash
+# array.
+HTML_DOCS="htm/*"
+
+GAP_PKG_EXTRA_INSTALL=( ctbltoc data dlnames doc2 gap4 )
+
+gap-pkg_enable_tests
+
+src_install() {
+ gap-pkg_src_install
+
+ # This package has a "doc2" directory that contains an entirely
+ # separate set of GAPDoc documentation called "CTblLibXpls." They
+ # are mentioned in PackageInfo.g. On the assumption that "Xpls"
+ # stands for "examples," we install it (unconditionally, and via
+ # symlink) as "examples" by copying most of the GAPDoc installation
+ # bits from gap-pkg_src_install().
+ pushd doc2 > /dev/null || die
+
+ local docdir="$(gap-pkg_dir)/doc2"
+ insinto "${docdir}"
+
+ local f
+ for f in *.{lab,six,txt,xml}; do
+ doins "${f}"
+ done
+
+ for f in *.pdf; do
+ doins "${f}"
+ dosym -r "${docdir}/${f}" "/usr/share/doc/${PF}/examples/${f}"
+ done
+
+ for f in *.{html,css,js,png}; do
+ doins "${f}"
+ dosym -r "${docdir}/${f}" "/usr/share/doc/${PF}/examples/html/${f}"
+ done
+
+ popd > /dev/null || die
+}
diff --git a/dev-gap/ctbllib/metadata.xml b/dev-gap/ctbllib/metadata.xml
new file mode 100644
index 000000000000..df52135df9e1
--- /dev/null
+++ b/dev-gap/ctbllib/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+</pkgmetadata>