summaryrefslogtreecommitdiff
path: root/dev-games/wfmath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/wfmath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/wfmath')
-rw-r--r--dev-games/wfmath/Manifest3
-rw-r--r--dev-games/wfmath/metadata.xml20
-rw-r--r--dev-games/wfmath/wfmath-1.0.2.ebuild33
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-games/wfmath/Manifest b/dev-games/wfmath/Manifest
new file mode 100644
index 000000000000..d1a2b75298a7
--- /dev/null
+++ b/dev-games/wfmath/Manifest
@@ -0,0 +1,3 @@
+DIST wfmath-1.0.2.tar.bz2 399987 BLAKE2B d299a6d90a37a90daa6a86e0ddad15201c1a5ee247159633ba68fcb6d0df1205bd60869e73d4849b923f3dd8142a167348bdac6764dda7a3b9857d9b9eae5701 SHA512 3506dbaed5db914b0be5483d5b589d95ed495b6375384e4b045844f8d76240f97b5c322ac432faf177f16da0fedd0b0e6006877a9b40e7f5d31d3324efa6de57
+EBUILD wfmath-1.0.2.ebuild 619 BLAKE2B 3624bdc9bd0cf236c26065946165edd45e58e1f725d3a5c75960a6f3327995625d7f6a76c7960af485c677fc317fca1b4ce2623d014b616627dd869be7b69cbe SHA512 e62f658eb953f0ceaae142780b5cac6500b00ba60b7778b21ceff9743b08b073f0fc4889b721d6bd99b576bab59eaaf3550e1f1a3c7098072a1697abde2dcdaa
+MISC metadata.xml 834 BLAKE2B b2d412774009fe2c79f1491f1a32b58d8666e7a1bfcfb75f3a9322618094a05d86104976693d386389718d8a07be41125e867ea9915714bfc182dc507f03179b SHA512 c99727d8b00129b35865cf778eb9d6c438e53189982b54a87a2463e3664d98572f24d4fe3b7d814c2d19bfe52bafc4df4be155d68f2cc177523ede9ac104deac
diff --git a/dev-games/wfmath/metadata.xml b/dev-games/wfmath/metadata.xml
new file mode 100644
index 000000000000..a41dc201202f
--- /dev/null
+++ b/dev-games/wfmath/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+The primary focus of WFMath is geometric objects. Thus, it includes several
+shapes (boxes, balls, lines), in addition to the basic math objects that are
+used to build these shapes (points, vectors, matricies).
+Most of the library classes can be divided into two sorts. The first kind are
+basic mathematical objects, whose members are all fundamental types. The second
+kind are shapes, which implement the shape class interface described in
+doc/shape.h.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">worldforge</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/wfmath/wfmath-1.0.2.ebuild b/dev-games/wfmath/wfmath-1.0.2.ebuild
new file mode 100644
index 000000000000..096663843a6f
--- /dev/null
+++ b/dev-games/wfmath/wfmath-1.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Worldforge math library"
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C doc docs
+}
+
+src_install() {
+ default
+ use doc && dohtml doc/html/*
+ prune_libtool_files
+}