summaryrefslogtreecommitdiff
path: root/dev-games/t4k-common
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/t4k-common
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/t4k-common')
-rw-r--r--dev-games/t4k-common/Manifest4
-rw-r--r--dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch18
-rw-r--r--dev-games/t4k-common/metadata.xml8
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1.ebuild46
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-games/t4k-common/Manifest b/dev-games/t4k-common/Manifest
new file mode 100644
index 000000000000..d65982721b85
--- /dev/null
+++ b/dev-games/t4k-common/Manifest
@@ -0,0 +1,4 @@
+AUX t4k-common-0.1.1-libpng.patch 799 BLAKE2B 3248451847f0b06a2926287b6af09eb2d86aa234cff7a640f499a849955f3faa1646264cbdcace7a30024124fbc647fe5283b96339cc8e55850cec616cce5ac4 SHA512 e9d8c4a2487d972231ef631feac67cea679ec585faf0453cf513290f318778070222b6e9a54725f18f5ea874c009a370ec55245a05151e9ecf19403b876be6ac
+DIST t4k_common-0.1.1.tar.gz 629215 BLAKE2B e85619ae0526aa51dc2075e5b845eaf778772cc7b354cb2a8d6737602695dbeea798de980ddefce1ec951b3700059a936bef291f140acf6424001e6647fe8643 SHA512 ddf9c0ccf1b6a4ab9f009794262fef86587e31e5110e5a8041214d7c94c607b9f4ca5ec21f04254bfc00a625ab75a04a69b3dcaff9ec13dbb92d5d82b6e375cf
+EBUILD t4k-common-0.1.1.ebuild 947 BLAKE2B 1bfcbfcd154eac5bec5910858977634c890331596140c6a34644bf8478c3b981ed1ee8f6c7daba232fd9bb893e1afe6c7d016587b325daf8ab1dc5feadbd1e96 SHA512 80e8688b02901af87c5c38c518f382fb0147bdb26aafc2aaa15e5749116a7b1ea6c4140f2cf223e1f34bf4dd01a96a238d4b345873d54375921c3f0e792a792a
+MISC metadata.xml 253 BLAKE2B 443ca9c8d4f6801169382e87a0ecd1385c56e65229209e7200f9d313ef380e92ae8d7dc3c38e5989a4166289f22607a20b1e13bb960fff6b3d9f78629d8ab020 SHA512 61c4689cbc649d84a00be211b7b5b98dd03e1d3f813eff370df549f2998cd4343f391c18b57cf20e4a8f4dd2311e3bfa04eb60f356f2bbac78f0b68f5091f254
diff --git a/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
new file mode 100644
index 000000000000..29991544ddbf
--- /dev/null
+++ b/dev-games/t4k-common/files/t4k-common-0.1.1-libpng.patch
@@ -0,0 +1,18 @@
+--- src/t4k_common-0.1.1/src/t4k_loaders.c 2011-04-08 05:46:07.000000000 +0300
++++ src.new/t4k_common-0.1.1/src/t4k_loaders.c 2012-05-02 10:35:41.836670434 +0300
+@@ -1028,12 +1028,9 @@
+ {
+ png_init_io(png_ptr, fi);
+
+- info_ptr->width = surf->w;
+- info_ptr->height = surf->h;
+- info_ptr->bit_depth = 8;
+- info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA;
+- info_ptr->interlace_type = 1;
+- info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */
++ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8,
++ PNG_COLOR_TYPE_RGB_ALPHA, 1,
++ PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
+
+ png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
+ PNG_sRGB_INTENT_PERCEPTUAL);
diff --git a/dev-games/t4k-common/metadata.xml b/dev-games/t4k-common/metadata.xml
new file mode 100644
index 000000000000..26079e608bed
--- /dev/null
+++ b/dev-games/t4k-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-games/t4k-common/t4k-common-0.1.1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
new file mode 100644
index 000000000000..ed40644465c3
--- /dev/null
+++ b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library of code shared between tuxmath and tuxtype"
+HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/download.php"
+SRC_URI="http://alioth.debian.org/frs/download.php/3540/t4k_common-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs svg"
+
+RDEPEND="dev-libs/libxml2:2
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-pango
+ svg? (
+ gnome-base/librsvg:2
+ media-libs/libpng:0
+ x11-libs/cairo
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/t4k_common-${PV}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng.patch
+}
+
+src_configure() {
+ econf \
+ $(usex svg "" "--without-rsvg") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files --all
+}