summaryrefslogtreecommitdiff
path: root/dev-games/recastnavigation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-games/recastnavigation
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-games/recastnavigation')
-rw-r--r--dev-games/recastnavigation/Manifest4
-rw-r--r--dev-games/recastnavigation/files/recastnavigation-1.5.1_p20200511-install.patch115
-rw-r--r--dev-games/recastnavigation/metadata.xml16
-rw-r--r--dev-games/recastnavigation/recastnavigation-1.5.1_p20200511.ebuild33
4 files changed, 168 insertions, 0 deletions
diff --git a/dev-games/recastnavigation/Manifest b/dev-games/recastnavigation/Manifest
new file mode 100644
index 000000000000..774a040d724e
--- /dev/null
+++ b/dev-games/recastnavigation/Manifest
@@ -0,0 +1,4 @@
+AUX recastnavigation-1.5.1_p20200511-install.patch 4029 BLAKE2B 7167a92f5763887f073110f04e0965745ff2114579d8a35c5c7c2480f3787aec3929f83b443e585852d268891fa279a91577a73b3bdebee0aee9c10a66afdd7f SHA512 da2c1bf75328729ef9679e2ac6cd9446b7b950ece6b6f343c0e015cc872c1e69e9fd27c9a6781a62cf6f8c845b82133d4df4ccefde8cbc3983258896d346ffc4
+DIST recastnavigation-1.5.1_p20200511.tar.gz 1541540 BLAKE2B 3878294247e26421c33019c05a8d70f9ae04ce046d1e503b2df8297e5c390c592e0222c445c9a7798c2e3eb7090b6c32d18b94015dce0a248ab17198d3054dda SHA512 bc48d9195c1ce4422359d850ad422e53c2599ff575b8c7a0ce6b7dc42720d7edd99781a1efa7bee49a00cd4ce6734f34ce9d434421471cb0cbf8e5207bbebebc
+EBUILD recastnavigation-1.5.1_p20200511.ebuild 811 BLAKE2B a5ba8c158dadc09cc59c53504d425696a2665fe5e529c05d833499c56f3f6abc78d1fa8cec56e5cad475934c676ff53510d771defd2d955878a8f2898dfca03b SHA512 0c9d9be8c118a5ee78b1d2429c52a2dcaf4249877518f714fe350d3b375ab37a622dd9723fdcdc989f0a13d9e244528b15bb2948508552886cbea82730ac38a0
+MISC metadata.xml 487 BLAKE2B f05f7dfccc42f908aa0d3e886bbe5a631e08d6e33babe10e1a5844cd48930c481873c843b8954926413334e8887c6d392412821ed173036a25349ae25afb8948 SHA512 54a6c615a69a2ba3e482e7ce37d556afa7bca8fa68cff67919aed151eb84ea38496a5a439c333ac1699db0085990f4a1d5ea221ec18997a7fcc93b9442d896d0
diff --git a/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20200511-install.patch b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20200511-install.patch
new file mode 100644
index 000000000000..8017517b448a
--- /dev/null
+++ b/dev-games/recastnavigation/files/recastnavigation-1.5.1_p20200511-install.patch
@@ -0,0 +1,115 @@
+https://github.com/recastnavigation/recastnavigation/pull/437
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d23859d..54a38d8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -11,6 +11,8 @@ option(RECASTNAVIGATION_TESTS "Build tests" ON)
+ option(RECASTNAVIGATION_EXAMPLES "Build examples" ON)
+ option(RECASTNAVIGATION_STATIC "Build static libraries" ON)
+
++include(GNUInstallDirs)
++
+ add_subdirectory(DebugUtils)
+ add_subdirectory(Detour)
+ add_subdirectory(DetourCrowd)
+diff --git a/DebugUtils/CMakeLists.txt b/DebugUtils/CMakeLists.txt
+index 8b6a3fc..86cfe76 100644
+--- a/DebugUtils/CMakeLists.txt
++++ b/DebugUtils/CMakeLists.txt
+@@ -26,10 +26,10 @@ set_target_properties(DebugUtils PROPERTIES
+ )
+
+ install(TARGETS DebugUtils
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT library
+ )
+
+ file(GLOB INCLUDES Include/*.h)
+-install(FILES ${INCLUDES} DESTINATION include)
++install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
+diff --git a/Detour/CMakeLists.txt b/Detour/CMakeLists.txt
+index de88111..b4c457a 100644
+--- a/Detour/CMakeLists.txt
++++ b/Detour/CMakeLists.txt
+@@ -20,10 +20,10 @@ set_target_properties(Detour PROPERTIES
+ )
+
+ install(TARGETS Detour
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT library
+ )
+
+ file(GLOB INCLUDES Include/*.h)
+-install(FILES ${INCLUDES} DESTINATION include)
++install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
+diff --git a/DetourCrowd/CMakeLists.txt b/DetourCrowd/CMakeLists.txt
+index 73cdf7c..7d1ace3 100644
+--- a/DetourCrowd/CMakeLists.txt
++++ b/DetourCrowd/CMakeLists.txt
+@@ -24,10 +24,10 @@ set_target_properties(DetourCrowd PROPERTIES
+ )
+
+ install(TARGETS DetourCrowd
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT library
+ )
+
+ file(GLOB INCLUDES Include/*.h)
+-install(FILES ${INCLUDES} DESTINATION include)
++install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
+diff --git a/DetourTileCache/CMakeLists.txt b/DetourTileCache/CMakeLists.txt
+index 121b8ed..141a680 100644
+--- a/DetourTileCache/CMakeLists.txt
++++ b/DetourTileCache/CMakeLists.txt
+@@ -25,10 +25,10 @@ set_target_properties(DetourTileCache PROPERTIES
+
+
+ install(TARGETS DetourTileCache
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT library
+ )
+
+ file(GLOB INCLUDES Include/*.h)
+-install(FILES ${INCLUDES} DESTINATION include)
++install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
+diff --git a/Recast/CMakeLists.txt b/Recast/CMakeLists.txt
+index 5e84376..3b04742 100644
+--- a/Recast/CMakeLists.txt
++++ b/Recast/CMakeLists.txt
+@@ -20,10 +20,10 @@ set_target_properties(Recast PROPERTIES
+ )
+
+ install(TARGETS Recast
+- ARCHIVE DESTINATION lib
+- LIBRARY DESTINATION lib
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ COMPONENT library
+ )
+
+ file(GLOB INCLUDES Include/*.h)
+-install(FILES ${INCLUDES} DESTINATION include)
++install(FILES ${INCLUDES} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/recastnavigation)
+diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
+index 7c17469..a98ccbf 100644
+--- a/Tests/CMakeLists.txt
++++ b/Tests/CMakeLists.txt
+@@ -8,5 +8,3 @@ add_executable(Tests ${TESTS_SOURCES})
+ add_dependencies(Tests Recast Detour)
+ target_link_libraries(Tests Recast Detour)
+ add_test(Tests Tests)
+-
+-install(TARGETS Tests RUNTIME DESTINATION bin)
diff --git a/dev-games/recastnavigation/metadata.xml b/dev-games/recastnavigation/metadata.xml
new file mode 100644
index 000000000000..476961fc1b94
--- /dev/null
+++ b/dev-games/recastnavigation/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-games/recastnavigation/recastnavigation-1.5.1_p20200511.ebuild b/dev-games/recastnavigation/recastnavigation-1.5.1_p20200511.ebuild
new file mode 100644
index 000000000000..ca12783c1d9f
--- /dev/null
+++ b/dev-games/recastnavigation/recastnavigation-1.5.1_p20200511.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Navigation mesh construction toolset for games"
+HOMEPAGE="https://github.com/recastnavigation/recastnavigation"
+MY_COMMIT="df27e4eb1a4ade9912f8b7d75c25769a3193dbd0"
+SRC_URI="https://github.com/recastnavigation/recastnavigation/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/recastnavigation-1.5.1_p20200511-install.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DRECASTNAVIGATION_DEMO=OFF
+ -DRECASTNAVIGATION_EXAMPLES=OFF
+ -DRECASTNAVIGATION_STATIC=OFF
+ -DRECASTNAVIGATION_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}