summaryrefslogtreecommitdiff
path: root/dev-games/ps2-packer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-games/ps2-packer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-games/ps2-packer')
-rw-r--r--dev-games/ps2-packer/Manifest3
-rw-r--r--dev-games/ps2-packer/metadata.xml11
-rw-r--r--dev-games/ps2-packer/ps2-packer-0.4.4.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-games/ps2-packer/Manifest b/dev-games/ps2-packer/Manifest
new file mode 100644
index 000000000000..cfb263552160
--- /dev/null
+++ b/dev-games/ps2-packer/Manifest
@@ -0,0 +1,3 @@
+DIST ps2-packer-0.4.4-linux.tar.gz 56579 BLAKE2B 42134434bc21f5a9b26dd6f47c5bdd6c824a603366d216541e5b3129648d39133ca49c396cbcdbd78495208da963dfe5425a501342698a763a99b2fddafca41d SHA512 491f662af5364fe0177a9a6676a80ae218a941f68c00bb7bc375f2002e61ea98afa58d6dd0c1f7e225e5659bd28e82c25128058edebb9dfb1794d297f090a28d
+EBUILD ps2-packer-0.4.4.ebuild 1532 BLAKE2B 742f1da11547caa8114ea48c2c6ffb2ceaa8cca4bfb20c2c0a22b85d89a5827b9f577c3b0452710c579c644f137d0777d48a18d0e246eb3aa1255c94b21a29b7 SHA512 2433468255c7278638482d0c6ace2f046c6aae974b4f8579bdb8208a597a39eb5d57d9654b30f0442d57a4bb593832af3fed0e179352db0bc96cc2015499d796
+MISC metadata.xml 345 BLAKE2B 36f1bf9af65d709f504951c0bdaf56eefe28a73785ffc8f6d80eb92fb8f2edea38e17f403a42be3b8e31c75f27da63df8e1d891599e1379f10b12000d5e39c0f SHA512 8eb0407ee72d763fe913a0a68915e9d2bd79daab7e16e96833d4318280d0a93dec7d1caada674815f16d6b62d6fd2ab1a1be63935977e1486d486eaca33f4ad7
diff --git a/dev-games/ps2-packer/metadata.xml b/dev-games/ps2-packer/metadata.xml
new file mode 100644
index 000000000000..e259e7a8037c
--- /dev/null
+++ b/dev-games/ps2-packer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ps2dev/ps2-packer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild b/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild
new file mode 100644
index 000000000000..3354575677ff
--- /dev/null
+++ b/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit games
+
+DESCRIPTION="another ELF packer for the PS2"
+HOMEPAGE="https://github.com/ps2dev/ps2-packer"
+SRC_URI="mirror://gentoo/${P}-linux.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+QA_TEXTRELS="
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/n2e-packer.so
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/n2d-packer.so
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/n2b-packer.so"
+
+QA_WX_LOAD="
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-0088-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/lzo-0088-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-asm-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/null-0088-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-asm-one-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/zlib-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2b-0088-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2d-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/null-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2b-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/zlib-0088-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/lzo-1d00-stub
+ ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2d-0088-stub"
+
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}"/${PN}
+ doins -r README.txt stub
+ exeinto "${GAMES_PREFIX_OPT}"/${PN}
+ doexe *.so ps2-packer
+ games_make_wrapper ${PN} "${GAMES_PREFIX_OPT}"/${PN}/${PN}
+ prepgamesdirs
+}