summaryrefslogtreecommitdiff
path: root/dev-games/ps2-packer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-games/ps2-packer
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-games/ps2-packer')
-rw-r--r--dev-games/ps2-packer/Manifest2
-rw-r--r--dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild49
-rw-r--r--dev-games/ps2-packer/ps2-packer-0.4.4.ebuild49
3 files changed, 50 insertions, 50 deletions
diff --git a/dev-games/ps2-packer/Manifest b/dev-games/ps2-packer/Manifest
index cfb263552160..bee1cc97ae84 100644
--- a/dev-games/ps2-packer/Manifest
+++ b/dev-games/ps2-packer/Manifest
@@ -1,3 +1,3 @@
DIST ps2-packer-0.4.4-linux.tar.gz 56579 BLAKE2B 42134434bc21f5a9b26dd6f47c5bdd6c824a603366d216541e5b3129648d39133ca49c396cbcdbd78495208da963dfe5425a501342698a763a99b2fddafca41d SHA512 491f662af5364fe0177a9a6676a80ae218a941f68c00bb7bc375f2002e61ea98afa58d6dd0c1f7e225e5659bd28e82c25128058edebb9dfb1794d297f090a28d
-EBUILD ps2-packer-0.4.4.ebuild 1532 BLAKE2B 742f1da11547caa8114ea48c2c6ffb2ceaa8cca4bfb20c2c0a22b85d89a5827b9f577c3b0452710c579c644f137d0777d48a18d0e246eb3aa1255c94b21a29b7 SHA512 2433468255c7278638482d0c6ace2f046c6aae974b4f8579bdb8208a597a39eb5d57d9654b30f0442d57a4bb593832af3fed0e179352db0bc96cc2015499d796
+EBUILD ps2-packer-0.4.4-r1.ebuild 1149 BLAKE2B ff6045d0a92bbf56c5532f891052e20955d5ce6a2240c408c9177b5e96099998532477bf4d000429100b051a99db57c02462b93b98ce06b476ecf17fa3a8303f SHA512 8d9870e7ad29222462f8285c364999563346cc911e2dcd0941ecb8f5ea3b12b470803a6833692ae82e567a36d91cbca62f16317f8eb3144d5e89ffdb880f3c66
MISC metadata.xml 345 BLAKE2B 36f1bf9af65d709f504951c0bdaf56eefe28a73785ffc8f6d80eb92fb8f2edea38e17f403a42be3b8e31c75f27da63df8e1d891599e1379f10b12000d5e39c0f SHA512 8eb0407ee72d763fe913a0a68915e9d2bd79daab7e16e96833d4318280d0a93dec7d1caada674815f16d6b62d6fd2ab1a1be63935977e1486d486eaca33f4ad7
diff --git a/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild b/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..5d3ee26ac3e7
--- /dev/null
+++ b/dev-games/ps2-packer/ps2-packer-0.4.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit wrapper
+
+DESCRIPTION="Another ELF packer for the PS2"
+HOMEPAGE="https://github.com/ps2dev/ps2-packer"
+SRC_URI="mirror://gentoo/${P}-linux.tar.gz"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+RESTRICT="strip"
+
+QA_TEXTRELS="
+ opt/ps2-packer/n2e-packer.so
+ opt/ps2-packer/n2d-packer.so
+ opt/ps2-packer/n2b-packer.so"
+
+QA_WX_LOAD="
+ opt/ps2-packer/stub/n2e-0088-stub
+ opt/ps2-packer/stub/lzo-0088-stub
+ opt/ps2-packer/stub/n2e-asm-1d00-stub
+ opt/ps2-packer/stub/null-0088-stub
+ opt/ps2-packer/stub/n2e-asm-one-1d00-stub
+ opt/ps2-packer/stub/n2e-1d00-stub
+ opt/ps2-packer/stub/zlib-1d00-stub
+ opt/ps2-packer/stub/n2b-0088-stub
+ opt/ps2-packer/stub/n2d-1d00-stub
+ opt/ps2-packer/stub/null-1d00-stub
+ opt/ps2-packer/stub/n2b-1d00-stub
+ opt/ps2-packer/stub/zlib-0088-stub
+ opt/ps2-packer/stub/lzo-1d00-stub
+ opt/ps2-packer/stub/n2d-0088-stub"
+
+RDEPEND="sys-libs/glibc"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r README.txt stub
+
+ exeinto /opt/${PN}
+ doexe *.so ps2-packer
+
+ make_wrapper ${PN} /opt/${PN}/${PN}
+}
diff --git a/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild b/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild
deleted file mode 100644
index 3354575677ff..000000000000
--- a/dev-games/ps2-packer/ps2-packer-0.4.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit games
-
-DESCRIPTION="another ELF packer for the PS2"
-HOMEPAGE="https://github.com/ps2dev/ps2-packer"
-SRC_URI="mirror://gentoo/${P}-linux.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 x86"
-IUSE=""
-RESTRICT="strip"
-
-QA_TEXTRELS="
- ${GAMES_PREFIX_OPT:1}/ps2-packer/n2e-packer.so
- ${GAMES_PREFIX_OPT:1}/ps2-packer/n2d-packer.so
- ${GAMES_PREFIX_OPT:1}/ps2-packer/n2b-packer.so"
-
-QA_WX_LOAD="
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-0088-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/lzo-0088-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-asm-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/null-0088-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-asm-one-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2e-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/zlib-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2b-0088-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2d-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/null-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2b-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/zlib-0088-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/lzo-1d00-stub
- ${GAMES_PREFIX_OPT:1}/ps2-packer/stub/n2d-0088-stub"
-
-RDEPEND="sys-libs/glibc"
-
-S=${WORKDIR}
-
-src_install() {
- insinto "${GAMES_PREFIX_OPT}"/${PN}
- doins -r README.txt stub
- exeinto "${GAMES_PREFIX_OPT}"/${PN}
- doexe *.so ps2-packer
- games_make_wrapper ${PN} "${GAMES_PREFIX_OPT}"/${PN}/${PN}
- prepgamesdirs
-}