summaryrefslogtreecommitdiff
path: root/dev-games/physfs/physfs-3.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-games/physfs/physfs-3.0.2.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-games/physfs/physfs-3.0.2.ebuild')
-rw-r--r--dev-games/physfs/physfs-3.0.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-games/physfs/physfs-3.0.2.ebuild b/dev-games/physfs/physfs-3.0.2.ebuild
deleted file mode 100644
index 5973e8fad0a0..000000000000
--- a/dev-games/physfs/physfs-3.0.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="Abstraction layer for filesystem and archive access"
-HOMEPAGE="https://icculus.org/physfs/"
-
-if [[ ${PV} == *9999* ]]; then
- EHG_REPO_URI="https://hg.icculus.org/icculus/physfs"
- inherit mercurial
-else
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc64 x86"
- SRC_URI="https://icculus.org/physfs/downloads/${P}.tar.bz2"
-fi
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="7zip doc grp hog iso mvl qpak slb static-libs vdf wad +zip"
-
-BDEPEND="doc? ( app-doc/doxygen )"
-
-DOCS=( docs/CHANGELOG.txt docs/CREDITS.txt docs/TODO.txt )
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DPHYSFS_BUILD_SHARED=ON
- -DPHYSFS_BUILD_TEST=OFF
- -DPHYSFS_BUILD_STATIC="$(usex static-libs)"
- -DPHYSFS_ARCHIVE_7Z="$(usex 7zip)"
- -DPHYSFS_ARCHIVE_GRP="$(usex grp)"
- -DPHYSFS_ARCHIVE_HOG="$(usex hog)"
- -DPHYSFS_ARCHIVE_ISO9660="$(usex iso)"
- -DPHYSFS_ARCHIVE_MVL="$(usex mvl)"
- -DPHYSFS_ARCHIVE_SLB="$(usex slb)"
- -DPHYSFS_ARCHIVE_VDF="$(usex vdf)"
- -DPHYSFS_ARCHIVE_WAD="$(usex wad)"
- -DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
- -DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
- )
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
-
- if multilib_is_native_abi && use doc; then
- cmake_src_compile docs
- HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
- fi
-}